RubyMine 2020.2ヘルプ

外部ツール

スタンドアロンのサードパーティアプリケーションを外部ツールとして定義し、RubyMineから実行できます。

プロジェクトからコンテキスト情報をコマンドライン引数(たとえば、現在選択されているファイル、開いているファイル、プロジェクトのソースパスなど)として外部ツールに渡したり、ツールによって生成された出力を表示したり、実行/デバッグ構成などの前にツールを使用します。

RubyMineで使用できるさまざまな種類の外部ツールがあります。

  • ローカル外部ツールはあなたのマシン上でローカルに動作するアプリケーションです。

  • リモート SSH 外部ツールはSSHを介してリモートサーバー上で実行されます。

ローカル外部ツールを追加する

多くのイメージエディターは、最適化されていないpngイメージを作成します。イメージを最適化するには、OptiPNG(英語)コマンドラインツールを使用できます。RubyMineで使用できるように設定しましょう。

  1. 設定/環境設定ダイアログ Ctrl+Alt+Sで、ツール | 外部ツールを選択します。

  2. the Add button をクリックして、以下の設定を指定します。

    The Create Tool dialog
    • 名前 : RubyMineインターフェース(ツールメニューとコンテキストメニュー)に表示されるツールの名前。

    • グループ : ツールが属するグループの名前。既存のグループを選択するか、または新しいグループの名前を入力できます。

    • 説明 : ツールのわかりやすい説明。

    • プログラム : 実行可能ファイルの名前。含んでいるディレクトリが PATH 環境変数にない場合は、絶対パスで指定してください。

    • 引数 : コマンドラインで指定したように、引数は実行可能ファイルに渡されます。

    • 作業ディレクトリ : ツールが実行される現在の作業ディレクトリへのパス。

  3. OKをクリックしてツールを追加してから変更を適用します。

追加されたローカル外部ツールを実行する

選択したイメージに対して追加したツールを実行するには、次のいずれかを実行します。

  • メインメニューからツール | イメージング | PNGの最適化を選択します。

  • プロジェクトツールウィンドウでファイルを右クリックして、コンテキストメニューからイメージング | PNGの最適化を選択します。

  • 設定/環境設定ダイアログ Ctrl+Alt+Sキーマップを選択し、外部ツールノードでPNGの最適化アクションを見つけて、ショートカットを割り当てます。ショートカットを使用してツールを実行します。

ツールが実行されると、その出力が実行ツールウィンドウに表示されます。

Running External Tool

リモート SSH外部ツールを追加する

リモート SSH外部ツールはローカルの外部ツールと同様に設定されていますが、それらが実行されるリモートサーバーも定義しており、SSH経由で接続するための認証情報が必要です。

この例では、リモートサーバー上で実行され、現在の日時を返すリモート SSH外部ツールとして date を追加する方法を示します。

  1. 設定/環境設定ダイアログ Ctrl+Alt+Sで、ツール | リモート SSH 外部ツールを選択します。

  2. the Add button をクリックして、以下の設定を指定します。

    The Create Tool dialog

    このダイアログでは、ローカル外部ツールを追加する場合と同じ設定セットが提供されますが、リモートサーバーを選択することも推奨されます。これは、構成済みのSSH 構成またはVagrantボックスのいずれかです。デフォルトでは、RubyMineは、サーバーでツールを実行するたびに、ホスト、ポート、および関連するSSH認証情報を要求します。

  3. OKをクリックしてツールを追加してから変更を適用します。

追加されたツールをリモートサーバーで実行する

  • メインメニューからツール | リモートツール | 日時を選択します。

  • 設定/環境設定ダイアログ Ctrl+Alt+Sキーマップを選択し、Date and time アクションを見つけて、それにショートカットを割り当てます。ショートカットを使用してツールを実行します。

ホスト、ポート、および資格情報を指定した後、RubyMineはSSH経由でサーバーに接続して date コマンドを実行し、RubyMineの実行ツールウィンドウに出力を返します。

Web ブラウザー

Webブラウザを使用してプロジェクトから任意のファイルを開くことができますが、通常はHTMLファイルの出力をプレビューしたり、Webアプリケーションを実行したりデバッグしたりするために使用されます。

Webブラウザでファイルを開く

Webブラウザー(HTML、XML、JSPなど)によってレンダリングされることを意図したファイルを開くには、次のいずれかを実行します。

  • Alt+F2を押します。

  • ファイルを右クリックしてブラウザーで開くを選択します。

  • メインメニューから表示 | ブラウザーで開くを選択します。

  • エディターウィンドウの右上にあるブラウザポップアップを使用します。ブラウザボタンをクリックしてWebサーバーファイルのURLを開くか、Shift+Click をクリックしてローカルファイルのURLを開きます。

    Show in browser

ブラウザーで開くアクションは、他のファイルタイプでは使用できません。ただし、アクションの検索 Ctrl+Shift+Aを使用して実行することはできます。

RubyMineはデフォルトで、いくつかの最も人気のあるブラウザーをサポートします。これらのブラウザーは、可能な場合は自動的に構成されます。

  • Chrome Chrome browser icon

  • Firefox Firefox browser icon

  • Safari Safari browser icon

  • Opera Opera browser icon

  • Internet Explorer Internet Explorer browser icon

  • エッジ Edge browser icon

ブラウザーのリストを表示および構成する

  • 設定/環境設定ダイアログ Ctrl+Alt+Sで、ツール | Web ブラウザーを選択します。

The Web Browsers page in Preferences

標準の手順を使用してブラウザをインストールした場合は、パスフィールドのエイリアスが正しい場所を指しているはずです。そうでない場合は、対応する実行可能ファイルへのパスを指定します。

リスト内のブラウザの順序は、ポップアップ、コンテキストメニュー、および表示メニューの順序に対応しています。ブラウザを無効にすると、ポップアップ、コンテキストメニュー、および表示メニューに表示されません。

カスタムブラウザを追加する

  1. 設定/環境設定ダイアログ Ctrl+Alt+Sで、ツール | Web ブラウザーを選択します。

  2. the Add button をクリックして、ブラウザ名、ファミリ、および実行可能ファイルまたはmacOSアプリケーションの場所を指定します。

デフォルトのブラウザを選択

表示メニューおよびファイルのコンテキストメニューのブラウザーで開く項目には、利用可能なすべてのブラウザとデフォルトのブラウザが一覧表示されます。これらは外部リソースのレンダリングにも使用されます。

  1. 設定/環境設定ダイアログ Ctrl+Alt+Sで、ツール | Web ブラウザーを選択します。

  2. デフォルト・ブラウザーリストから、以下のいずれかを選択します。

    • システム・デフォルト : お使いのオペレーティングシステム用のデフォルトブラウザを使用してください。

    • 最初にリストされた : リストの最初のブラウザを使用してください。

    • カスタムパス : リストにないブラウザを使用してください。実行ファイルの場所を指定します。

カスタムプロファイルと設定を使用する

FirefoxおよびChromeファミリーブラウザ用のカスタムプロファイルを設定できます。

  1. 設定/環境設定ダイアログ Ctrl+Alt+Sで、ツール | Web ブラウザーを選択します。

  2. リストからブラウザを選択して the Edit buttonをクリックします。

    • Firefoxの場合は、profiles.iniファイルへのパスを指定し、使用するプロファイルを選択してください。詳しくは、Firefoxのブラウザプロファイル(英語)を参照してください。

    • Chromeの場合は、カスタムユーザーデータディレクトリを使用するを選択し、ユーザーデータディレクトリ(英語)の場所を指定します。

      RubyMineからChromeを実行するときに使用する追加のコマンドラインオプションを指定することもできます。詳細については、Chromeアドレスバーの chrome://flags を開いてください。

サードパーティのスタンドアロンアプリケーション(コードジェネレーターとアナライザー、プリプロセッサとポストプロセッサ、データベースユーティリティなど)を外部ツールとして定義して、RubyMineから実行できます。

外部ツールにコンテキスト情報(現在選択されているファイルやプロジェクトのソースパスなど)を渡したり、ツールの出力を表示したりすることができます。

ツールは、設定ダイアログ外部ツールページで定義され、ツールメニューおよびさまざまなコンテキストメニューにコマンドとして表示されます。キーボードショートカットを割り当てることもできます(キーボードとマウスのショートカットの設定のセクションを参照)。

最終更新日: 2020年8月19日

関連ページ:

SSH

RubyMineを使用すると、SSHを使用してリモートマシンを操作できます。事前定義されたSSH構成を作成し、それを使用してリモート SSHセッションを実行したり、リモート Rubyインタープリターを構成したり、データベースに接続したりできます。SSHをセットアップする:SSHを使用してリモートマシ...

Vagrant

Vagrantは、悪影響ファイル構成ファイルによって定義された仮想マシン環境を構築および管理するためのツールです。RubyMineはVagrantとの統合を提供し、Vagrant環境の初期化からVagrantコマンドの実行まで、プロジェクトで必要なすべてのアクションを実行できます。さらに、RubyM...

設定/環境設定ダイアログ

現在のプロジェクトに関連する設定はアイコンでマークされています。設定ダイアログでは、RubyMineの動作と外観を制御できます。ダイアログの左上部分にある検索フィールドを使用して、目的のオプションを見つけます。あるいは、検索ボックスにあるカテゴリの階層リスト(設定のグループ)を使用して設定を参照する...

外部ツール

macOSのRubyMine | 環境設定 | ツール | 外部ツールサードパーティのスタンドアロンアプリケーション(コードジェネレーターとアナライザー、プリプロセッサとポストプロセッサ、データベースユーティリティなど)を外部ツールとして定義して、RubyMineから実行できるようにします。外部ツー...

キーボードショートカットを設定する

RubyMineには定義済みのキーマップがいくつか含まれており、頻繁に使用するショートカットをカスタマイズできます。キーマップ構成を表示するには、設定/環境設定ダイアログ を開き、キーマップを選択します。RubyMineは、環境に基づいて事前定義されたキーマップを自動的に提案します。使用しているO...

ファイル監視

ファイル監視は、RubyMineツールであり、IDEでファイルを変更または保存するときに、コンパイラー、フォーマッター、またはlinterなどのコマンドラインツールを自動的に実行できます。ファイルウォッチャーには、2つの専用コードインスペクションがあります。ファイル監視使用可能インスペクションは、あ...