RubyMine 2020.3 ヘルプ

サービスツールウィンドウ

サービスツールウィンドウには、ソフトウェア開発中に役立つさまざまなサービスが含まれます。実行 / デバッグ構成、アプリケーションサーバー、データベースセッション、Docker 接続など。プラグイン開発者は IntelliJ プラットフォーム API を通して他のサービスを追加することができます。

メインツールバー

メインツールバーには、すべてのサービスタイプに共通の次のボタンとメニューが含まれています。

アイコン アクション 説明
The Expand All button すべて展開する Ctrl+NumPad + リスト内のすべての項目を展開します。
The Collapse All button すべて折りたたむ Ctrl+NumPad - リスト内のすべての項目を折りたたみます。
The Group By menu グループ化

サービスのリストを整理する方法を選択します。

The Filter menu フィルター サービスのリストをフィルタリングする方法を選択します。
The Open in New Tab button 新規タブで開く 選択した項目を別のタブに移動します。
The Add Service menu サービス Alt+Insert を追加 追加するサービスタイプを選択します。

実行 / デバッグ構成

実行 / デバッグ構成は、デフォルトではサービスツールウィンドウにリストされていません。使用可能にする構成のタイプを明示的に指定し、対応する構成を作成する必要があります。

サービスツールウィンドウに表示する構成の種類を追加する

  1. メインメニューから実行 | 実行構成の編集を選択するか、またはツールバーのセレクタを使用します。

  2. 実行 / デバッグ構成ダイアログで、左側のリストからテンプレートを選択します。

  3. 右側のペインで、サービスで利用可能な構成セクションを展開します。

  4. サービスで利用可能な構成セクションの the Add button をクリックして、必要な実行構成タイプを選択します。

    複数の構成タイプを 1 つずつ追加または削除できます。

    Enabling the Services tool window

    ツールウィンドウには、1 つ以上の構成を作成した構成タイプのみが表示されることに注意してください。

    プロジェクトに構成が存在しない構成タイプを追加した場合、このタイプの構成を作成するまで、このタイプはツールウィンドウに表示されません。

ツールバーのボタンは、選択した実行 / デバッグ構成の種類によって異なります。

アイコン アクション 説明
The Run button 実行 Ctrl+Shift+F10 選択した設定を実行します。
The Debug button デバッグ Ctrl+Shift+D 選択した設定をデバッグします。
The Stop button 停止 Ctrl+F2 選択した設定を停止します。

データベースサービス

データベースサービスでは、セッションと接続を管理できます。接続は物理的な通信チャネルであり、セッションは情報交換の状態です。例: ソーシャルネットワークを閲覧している場合、接続ログにはクライアントとサーバーの間に何千もの接続エントリがあり、セッションログには転送されたバイト数を含む単一のログエントリしか表示されません。

データベースセッションの管理の詳細については、データベースコードを実行するを参照してください。

左ツールバー

アイコン アクション 説明
Tx 送信モードと送信アイソレーション

データベーストランザクションの分離レベル(英語)とトランザクションのコミット方法を選択します。

  • 自動 : 各文は、暗黙的にコミットされた独自のトランザクションで実行されます。

  • マニュアル : トランザクションはコミットされ、手動でロールバックされます。

The Commit button コミット Ctrl+Alt+Shift+Enter 現在のトランザクションをコミットします。
The Rollback button ロールバック 最後のトランザクションをロールバックします。
The Cancel Running Statements button 実行中のステートメントをキャンセル 現在の文の実行を終了します。
The Restore Default Layout button デフォルトレイアウトに戻す Ctrl+F2 サービスビューの視覚要素のデフォルト位置を復元します。
The Jump to Console button コンソールにジャンプする Ctrl+Shift+F10

コンソールポップアップを開きます。コンソールポップアップで、エディターで開くクエリコンソールを選択できます。

The Disconnect button 切断 Ctrl+F2

(データソースの場合)選択したデータソースへの接続を閉じます。

The Disconnect button 実行中のステートメントをキャンセル

(セッションおよび添付ファイルの場合)選択したデータソースへの接続を閉じます。

データソース

アイコン アクション 説明
The Jump to Console button コンソールにジャンプする Ctrl+Shift+F10

コンソールポップアップを開きます。コンソールポップアップで、エディターで開くクエリコンソールを選択できます。

The Disconnect button 切断 Ctrl+F2

選択したデータソースへの接続を閉じます。

すべてのセッションを閉じる

データソースに対して開かれているすべてのセッションを閉じます。

The Show in New Tab button 新しいタブで表示 選択した項目を別のタブに移動します。
新規タブでそれぞれを開く 選択した項目を別々のタブに分割します。
新しいタブで各タブを開く サービスの種類ごとに別々のタブを作成します。
削除 Delete

データソースに対して開かれているすべてのセッションを閉じます。すべてのセッションを閉じると同じです。

セッション

アイコン アクション 説明
Tx 送信モードと送信アイソレーション

データベーストランザクションの分離レベル(英語)とトランザクションのコミット方法を選択します。

  • 自動 : 各文は、暗黙的にコミットされた独自のトランザクションで実行されます。

  • マニュアル : トランザクションはコミットされ、手動でロールバックされます。

The Commit button コミット Ctrl+Alt+Shift+Enter 現在のトランザクションをコミットします。
The Rollback button ロールバック 最後のトランザクションをロールバックします。
The Disconnect button 実行中のステートメントをキャンセル

実行中の文の実行を停止します。

The Restore Default Layout button デフォルトレイアウトに戻す Ctrl+F2 復元の視覚的要素が配置されています。
セッション名を変更します セッションの名前を指定できる名前の変更ダイアログを表示します。
セッションを閉じる 選択したセッションを閉じます。
The Show in New Tab button 新しいタブで表示 選択した項目を別のタブに移動します。
新規タブでそれぞれを開く 選択した項目を別々のタブに分割します。
新しいタブで各タブを開く サービスの種類ごとに別々のタブを作成します。
削除 Delete

データソースに対して開かれているすべてのセッションを閉じます。すべてのセッションを閉じると同じです。

SQL ファイル

アイコン アクション 説明
Tx 送信モードと送信アイソレーション

データベーストランザクションの分離レベル(英語)とトランザクションのコミット方法を選択します。

  • 自動 : 各文は、暗黙的にコミットされた独自のトランザクションで実行されます。

  • マニュアル : トランザクションはコミットされ、手動でロールバックされます。

The Commit button コミット Ctrl+Alt+Shift+Enter 現在のトランザクションをコミットします。
The Rollback button ロールバック 最後のトランザクションをロールバックします。
The Disconnect button 実行中のステートメントをキャンセル

実行中の文の実行を停止します。

The Restore Default Layout button デフォルトレイアウトに戻す Ctrl+F2 復元の視覚的要素が配置されています。
セッション切り替え 新しいセッションを選択または作成して接続できるセッションポップアップを表示します。
デタッチセッション

選択したファイルを現在のセッションから切り離します。ファイルをセッションに添付するには、エディターでファイルを開き、セッションリストでセッションを選択します。

Detach a session
The Show in New Tab button 新しいタブで表示 選択した項目を別のタブに移動します。
新規タブでそれぞれを開く 選択した項目を別々のタブに分割します。
新しいタブで各タブを開く サービスの種類ごとに別々のタブを作成します。
削除 Delete

データソースに対して開かれているすべてのセッションを閉じます。すべてのセッションを閉じると同じです。

the Jump to Source button ソース F4 にジャンプ

エディターでファイルを開きます。

Docker

このタイプのサービスは、少なくとも 1 つの Docker インスタンスに対して接続設定を構成している場合に利用可能です。詳しくは、Docker サポートを有効にするを参照してください。

Docker 接続を追加する

  1. the New Service menu をクリックし、Docker 接続を選択します。

  2. 新しい Docker 接続ダイアログで docker 接続設定を構成します。

メイン Docker ノード

アイコン アクション 説明
The Connect button 接続 Docker デーモンに接続して、使用可能なすべてのイメージとコンテナーをリストします。
The Disconnect button 切断 Docker デーモンから切断します。
The Edit Configuration button 構成の編集 Docker の接続設定を編集します。
The Deploy button 配置 既存の Docker 実行構成を選択するか、または新しい構成を作成してください。詳しくは、コンテナーの実行を参照してください。
The Pull Image button イメージのプル Docker レジストリからイメージを取得します。詳しくは、Docker レジストリからイメージを取得するを参照してください。
The Filter button フィルター 実行していないコンテナーやタグのないイメージを表示するか隠すかを選択します。

コンテナー

アイコン アクション 説明
The Start Container button コンテナーの開始 選択したコンテナーを実行します。
The Stop Container button コンテナーの停止 選択したコンテナーを停止します。
The Delete Container button コンテナーの削除 選択したコンテナーを削除します。
The Filter button フィルター 実行していないコンテナーやタグのないイメージを表示するか隠すかを選択します。

イメージ

アイコン アクション 説明
The Pull Image button イメージのプル Docker レジストリからイメージを取得します。詳しくは、Docker レジストリからイメージを取得するを参照してください。
The Create Container button コンテナーの作成 選択したイメージから Docker コンテナーを作成します。
The Delete Image button イメージの削除 選択したイメージを削除します。
The Push Image button イメージのプッシュ イメージを Docker レジストリにプッシュします。詳しくは、イメージを Docker レジストリにプッシュするを参照してください。
The Filter button フィルター 実行していないコンテナーやタグのないイメージを表示するか隠すかを選択します。

メイン Docker Compose ノード

アイコン アクション 説明
The Deploy button 配置 関連付けられた実行 / デバッグ構成を使用して、選択した Docker Compose サービスを配置します。詳しくは、Docker Compose を参照してください。
The Stop button 停止 選択した Docker Compose サービス内のすべてのコンテナーを停止します。
The Down button ダウン すべての関連ネットワーク、ボリューム、イメージを含む、選択した Docker Compose サービス内のすべてのコンテナーを停止して削除します。
The Edit Configuration button 構成の編集 選択した Docker Compose 実行構成を編集します。
The Filter button フィルター 実行していないコンテナーやタグのないイメージを表示するか隠すかを選択します。

Docker Compose サービス

アイコン アクション 説明
The Start button 開始 選択したサービスのすべてのコンテナーを起動します。
The Stop button 停止 選択したサービスのすべてのコンテナーを停止します。
The Scale button スケール 選択したサービスのコンテナー数を変更します。
The Delete Container button コンテナーの削除 選択したコンテナーを削除します。
The Filter button フィルター 実行していないコンテナーやタグのないイメージを表示するか隠すかを選択します。

Kubernetes

このタイプのサービスは次の場合に利用可能です。

  • Kubernetes プラグイン(英語)がインストールされ、有効になります。RubyMine での Kubernetes 統合の詳細については、Kubernetes を参照してください。

  • RubyMine は、Kubernetes クラスター構成ファイルを検出します。デフォルトでは、これは $HOME/.kube ディレクトリにある config という名前のファイルです。 KUBECONFIG 環境変数を設定することにより、他の kubeconfig ファイルを指定できます。kubeconfig ファイルの詳細については、kubeconfig ファイルを使用したクラスターアクセスの整理(英語)を参照してください。

サービスツールウィンドウの Kubernetes ノードには、選択したコンテキストの Kubernetes クラスターのリソースが一覧表示されます。

詳しくは、複数のクラスターへのアクセスを構成する(英語)を参照してください。

アイコン アクション 説明
The Refresh button リフレッシュ Kubernetes クラスターから情報をリフレッシュします。
The Namespace menu 名前空間 ネームスペースを選択して、クラスターのリストされたリソースをフィルターします。
The Context menu コンテキスト サービスツールウィンドウに表示されている Kubernetes コンテキストを選択します。これにより、実行中の Kubernetes クラスターのコンテキストは変更されません。
The Refresh Configuration button 構成のリフレッシュ kubeconfig ファイルから Kubernetes クラスター構成を読み取ります。
The Show Settings button 設定の表示

kubeconfig ファイルへのパスを変更できる Kubernetes クラスター設定を開きます。

設定ページの現在のプロジェクトに対してのみこのパスを設定チェックボックスを選択して、異なるプロジェクトで異なる設定ファイルを使用できます。

The Load YAML button YAML を読み込む

クラスターから選択したリソースの読み取り専用構成ファイルを表示します。

The Delete Resource button リソースの削除

選択したリソースをクラスターから削除します。

The Follow Log button ログをフォロー 選択した pod のコンテナーのログを出力します。
The Download Log button ログをダウンロード

選択した pod のコンテナーのログをスクラッチファイルに保存し、エディターで開きます。

スクラッチファイルを使用する代わりに、ログを保存するためのパスを設定したり、毎回場所を選択したりできます。pod ログのダウンロード場所を構成するには、The Show Settings button をクリックするか、設定 / 環境設定 | ビルド、実行、デプロイ | Kubernetes を開きます。

The Open Console button コンソールを開く 選択した pod のコンテナー内で実行されているプロセスのコンソールに接続します。
The Run Shell button シェルの実行

選択した pod のコンテナーに対してインタラクティブシェルを実行します。

デフォルトでは、RubyMine は /bin/bash を実行します。別のシェルを実行するには、The Show Settings button をクリックするか、設定 / 環境設定 | ビルド、実行、デプロイ | Kubernetes を開いて、pods が使用するシェルを指定します。

生産性のヒント

タブを使用

サービスツールウィンドウには多くのサービスを含めることができます。これらのサービスは、種類に応じてグループ化するか、独自のカスタムグループ化用に個別のタブを作成できます。例: 以下を含むタブを作成できます: 開発中のアプリケーションの実行構成、アプリケーションのバックエンドとして使用されるデータベースを実行する Docker コンテナー、およびデータベースにアクセスするためのコンソール。

サービスツリーを非表示にする

サービスツールウィンドウのツールバーの右側にある The Show Options Menu button をクリックし、次にサービスツリーの表示をクリックしてチェックボックスを外します。 Ctrl+Shift+T を押してサービスツリーを切り替えることもできます。

サービスツリーを非表示にすると、サービスナビゲーションバーに置き換えられます。 Alt+Home を押してサービスナビゲーションバーにフォーカスを合わせます。

サービスの非表示、削除、削除

サービスを右クリックし、削除 Delete を選択して、対応する実行構成、クラウドプロバイダー、Docker 接続などを完全に削除します。

特定のタイプの実行 / デバッグ構成をサービスツールウィンドウに表示したくない場合は、対応する構成を右クリックしてサービスから構成タイプを削除を選択します。これは実際の構成を削除しません。

サービスツールウィンドウから特定の実行構成を非表示にするには、対応する構成を右クリックして構成を非表示を選択します。すべての非表示の実行構成を表示するには、the Add Service menu をクリックして非表示の構成を復元を選択します。