JetBrains Rider 2019.1ヘルプ

ツール・ウィンドウで作業する

ワークスペースの下部と側面には、JetBrains Rider ツールウィンドウがアタッチされています。これらのセカンダリーウィンドウでは、プロジェクトをさまざまな視点から見て、典型的な開発タスクにアクセスできます。これらには、プロジェクト管理、ソースコードの検索とナビゲーション、実行とデバッグ、バージョン管理システムとの統合など、さまざまなタスクが含まれます。

特定のツールウィンドウは常に使用できます。つまり、ソリューションの性質、内容、および構成に関係なく、あらゆるソリューションで使用できます。他のツールウィンドウは、対応するプラグインが有効になっている場合にのみ利用可能です。特定の操作が実行されたときにのみ表示されるツールウィンドウもあります。例:検索ツール・ウィンドウを起動するには、検索を初期化する必要があります。

ツールウィンドウのクイックアクセス

ワークスペースの左下隅には、最初は次のようなボタンがあります: Icon for quick access to tool windows

このボタンの上にマウスカーソルを置くと、ツールウィンドウにすばやくアクセスできるメニューが開きます。

このボタンをクリックすると、ツールのウィンドウバーとボタンが表示されます。同時に、ボタンの外観が show hide tool window barsに切り替わります。もう一度ボタンをクリックすると、ツールウィンドウのバーとボタンは再び非表示になります。

ツールウィンドウのバーとボタン

表示されている場合、ツールウィンドウのボタンバー(またはツールウィンドウバーのみ )はツールウィンドウ(またはツールウィンドウが非表示の場合はエディター領域)の周囲にあります。これらのバーには、ツールウィンドウを表示または非表示にするためのボタン( ツールウィンドウボタン )が含まれています。

tool window bar and buttons

ツールウィンドウボタンは、ツールウィンドウボタンを右クリックすると表示されるツールウィンドウコンテキストメニューへのアクセスも提供します

tool window button context menu

コンテキストメニューを使用すると、ツールウィンドウの表示モードやその他のツールウィンドウの外観を制御できます。

最初は、メインウィンドウの両側に2つ、下部に1つのボタンバーが3つあります。ワークスペースの左下隅にある show hide tool window bars をクリックすると、すべてのボタンバーを同時に表示または非表示にすることができます。

各ツールウィンドウのボタンには、対応するツールウィンドウの名前が表示されます。特定のボタンでは、ウィンドウ名の前に数字を付けることができます(例:1: プロジェクト)。つまり、キーボードショートカット Alt+<number> ⌘+<number> は、ウィンドウを表示または非表示にすることができます。たとえば、Alt+1 ⌘+1を押して、プロジェクトツールウィンドウを表示または非表示にすることができます。

外観設定のボタンのウィンドウアクセス番号の表示/非表示を切り替えることができます。

表示されているツールウィンドウと隠れているツールウィンドウのボタンは、表示方法が異なります。

Buttons for visible and hidden tool windows

ツールウィンドウのボタンを別のツールウィンドウバー(または同じバーの別のコーナー)にドラッグアンドドロップすることによって、ツールウィンドウを再配置できます。結果として、ツールウィンドウは、ウィンドウボタンを移動したバーにアタッチされます。

tool window buttons drag

一般的なツールウィンドウのレイアウト

一般に、すべてのツールウィンドウは同様の方法で構成されています。

ウィンドウの上部にタイトルバーがあります。タイトルバーを右クリックすると、ウィンドウの外観と内容を管理するためのメニューが表示されます。

タイトルバーの右側には2つのボタンがあります。これらのボタンのうち最初のボタン(icons general gearPlain svg)は、ツールウィンドウの表示モードを管理するためのメニューを開きます。メニューオプションは、タイトルバーのコンテキストメニューのサブセットです。

tool window viewing modes

2番目のボタン(icon hideSide)はツールウィンドウを隠すためのボタンです。 Alt キーと組み合わせて使用する場合、このボタンをクリックすると、同じツールウィンドウバーに接続されているすべてのウィンドウが非表示になります。

タイトルバーには、ツールバーとコンテンツペインがあります。ウィンドウによっては、ツールバーがコンテンツペインの上または左にある場合があります。

ツールバーのボタンは、一般的にウィンドウ固有です。ただし、同様の目的のウィンドウには、ツールバーに同様のコントロールが含まれている場合があります。

ほとんどの場合、ツールバーボタンに関連付けられた機能には、メインメニューまたはコンテキストメニューからアクセスすることも、キーボードに相当する機能を含めることもできます。

コンテンツペインは、平らであってもよく、たとえばタブによって表される2つ以上の「レイヤー」(ビュー)を含んでもよい。エディター領域の別のタブに表示されているコンテンツペインの部分があるツールウィンドウもあります。

ツールウィンドウメニューにアクセスする

  • ツールウィンドウを表示または非表示にするには、表示 | ツール・ウィンドウメニューを使用します。

    other products toolWindowMenu

最終更新日: 2019年6月11日

関連事項

関連ページ:

プラグインを管理する

プラグインはJetBrains Riderのコア機能を拡張します。たとえば、以下のことができます。バージョン管理システム、アプリケーションサーバー、およびその他のツールとの統合を提供する、さまざまな言語とフレームワークのサポートを追加する、ショートカットヒント、ライブプレビュー、ファイルウォッチャー...

ツール・ウィンドウの表示モード

ツールウィンドウをさまざまな方法で表示および調整して、エディターまたは他のツールウィンドウで作業するときにすばやくアクセスしてスペースを節約できます。メインメニューからウィンドウ | アクティブ・ツール・ウィンドウ | 表示モードと実際のモードオプションを選択します。ツールウィンドウのタイトルバーで...

外観

このページで設定可能な設定は、ディレクトリーベースの設定のメカニズムを使用して保存されます。このページを使用して、IDEの全体的な外観を変更します。テーマリストから希望のテーマを選択します。ハイコントラストのテーマは、視力障害のある方にご利用いただけます。カスタム・フォントの使用カスタムフォントファ...

スクラッチ・ファイル

時々、一時的なメモを作成したり、プロジェクトのコンテキストの外側でコードを作成したりする必要があるかもしれません。この目的で別のアプリケーションに切り替える代わりに、スクラッチファイルとスクラッチバッファを使用できます。スクラッチ・ファイルは完全に機能的なファイルで、構文の強調表示、コード補完、およ...

ツール・ウィンドウの操作

ツールウィンドウを表示する:以下のいずれか 1 つを実行します:ワークスペースの左下隅にあるをポイントし、表示されるメニューでツールウィンドウを選択します。ツールウィンドウバーの対応するツールウィンドウボタンをクリックしてください。メインメニューの表示 | ツール・ウィンドウ | <ツールウィ...

キーボードショートカットの設定

JetBrains Riderには定義済みのキーマップが含まれており、頻繁に使用するショートカットをカスタマイズできます。キーマップ設定を表示するには、設定/環境設定ダイアログを開いてキーマップを選択します。JetBrains Riderはあなたの環境に基づいて自動的に事前定義されたキーマップを選択...