JetBrains Rider 2019.1ヘルプ

JetBrains Rider表示モード

JetBrains Riderには、以下の表示モードがあります。

  • 全画面表示モードを使用すると、画面全体をコーディングに使用できます。このモードでは、オペレーティングシステムコントロールだけでなく、ビューからすべてのメニューが削除されます。ただし、コンテキストメニューとキーボードショートカットを使用することができます。メインメニューは、マウスポインタを画面の上に置いたときにも利用できます。

  • プレゼンテーション・モード全画面表示モードに似ていますが、JetBrains Riderによるコーディングを含むプレゼンテーションを行うために設計されています。このモードでは、JetBrains Riderはフォントサイズを大きくし、エディター以外のすべてを隠します。必要に応じて、表示 | ツール・ウィンドウメニューの対応する項目を使用して、このビューにツールウィンドウを表示することもできます。

  • 集中モードにはツールバー、ツールウィンドウ、エディタータブはありません。コードは中央揃えになります。

これらのアクションは、表示メニューからのみ使用できます。デフォルトでは、ショートカットにはマッピングされていませんが、キーボードショートカットの設定に従って独自のショートカットを作成できます。

全画面モードを切り替える

ツールウィンドウの操作 (表示/非表示またはサイズ変更)に加えて、JetBrains Riderはメインメニューを隠して製品ウィンドウ全体を最大化することを可能にします。

  • 全画面モードに切り替えるには、メインメニューで表示 | 全画面表示にするを選択します。

  • 全画面モードに切り替えるには、Shift+Alt+Enter を押すか、メインメニューの表示 | 全画面表示にするを選択します。

  • 全画面モードを終了するには、メインメニューで表示 | 全画面表示を終了を選択します。

  • 全画面モードを終了するには、Shift+Alt+Enter を押すか、メインメニューの表示 | 全画面表示を終了を選択します。

プレゼンテーションモードを切り替える

プレゼンテーションモードでは、エディターは画面全体を占有し、他のすべてのJetBrains Riderコンポーネントは非表示になります。

それに加えて、このモードのフォントサイズは通常よりも大きくなります。プレゼンテーションモードのフォントサイズは、設定/環境設定ダイアログの外観ページで定義できます。

  • プレゼンテーションモードに切り替えるには、メインメニューで表示 | プレゼンテーション・モードにするを選択します。

  • プレゼンテーションモードを終了するには、メインメニューで表示 | プレゼンテーション・モードを終了を選択します。

集中モードを切り替える

集中モードでは、エディタータブとツールウィンドウボタンなしで、JetBrains Riderフレーム全体がエディターで占められます。コードは中央揃えです。

  • 集中モードに切り替えるには、メインメニューで表示 | 集中モードにするを選択します。

  • 集中モードを終了するには、表示 | 集中モードの終了を選択します。

切り替えリストで表示モードを切り替える

  1. N/A を押すか、メインメニューで表示 | スキームのクイック切り替えを選択します。

  2. 表示される切り替えリストで、表示モードを選択します。

  3. コンテキストメニューで、必要なモードを選択します。メニューの内容は、現在のモードによって異なります。
    • プレゼンテーション・モードにする / プレゼンテーション・モードを終了

    • 集中モードにする / 集中モードを終了

    • 全画面表示にする / 全画面表示を終了

最終更新日: 2019年6月11日

関連事項

リファレンス:

関連ページ:

キーボードショートカットの設定

JetBrains Riderには定義済みのキーマップが含まれており、頻繁に使用するショートカットをカスタマイズできます。キーマップ設定を表示するには、設定/環境設定ダイアログを開いてキーマップを選択します。JetBrains Riderはあなたの環境に基づいて自動的に事前定義されたキーマップを選択...

ツール・ウィンドウの操作

ツールウィンドウを表示する:以下のいずれか 1 つを実行します:ワークスペースの左下隅にあるをポイントし、表示されるメニューでツールウィンドウを選択します。ツールウィンドウバーの対応するツールウィンドウボタンをクリックしてください。メインメニューの表示 | ツール・ウィンドウ | <ツールウィ...

外観

このページで設定可能な設定は、ディレクトリーベースの設定のメカニズムを使用して保存されます。このページを使用して、IDEの全体的な外観を変更します。テーマリストから希望のテーマを選択します。ハイコントラストのテーマは、視力障害のある方にご利用いただけます。カスタム・フォントの使用カスタムフォントファ...

クイックリストの設定

クイックリストは、JetBrains Riderコマンドのカスタムセットを含み、キーボードまたはマウスのショートカットに関連付けられたポップアップです。必要に応じていくつでもクイックリストを作成できます。クイックリストに含まれている各コマンドは、連番で識別されます。番号付けは数字(0から9)から始ま...

背景画像を設定する

任意のイメージをJetBrains Riderのエディターとすべてのツールウィンドウのカスタム背景として設定できます。設定/環境設定ダイアログを開き、外観 & 振る舞い | 外観を選択し、背景画像ボタンをクリックします。背景画像ダイアログで、背景、不透明度、塗りつぶし、および配置のオプションとして使...