PyCharm 2020.2ヘルプ

テーブル

データベーステーブルは、データを行と列に編成する構造です。テーブル内のデータは、垂直列と水平行の交差部分であるセルに格納されます。テーブルには指定された数の列がありますが、任意の数の行を含めることができます。PyCharmを使用すると、テーブルを使用してデータ操作およびデータ定義操作を実行できます。

データベースツールウィンドウ(表示 | ツール・ウィンドウ | データベース)でテーブルをダブルクリックすると、テーブルがエディターでテーブルビューに表示されます。ビューの詳細については、データを表示するを参照してください。

PyCharmでは、各テーブルが個別のタブで開きます。長いタブタイトルには、次のルールが適用されます。

  • データベース・オブジェクトの修飾名を常に表示するオプションはデフォルトでオフになりました。同じ名前のオブジェクトの2つのタブを開くと、オブジェクトのタブ名が修飾されます。例:異なるスキーマから2つの actor テーブルを開くと、スキーマ名がタブ名に追加されます。

  • データソースの名前が20シンボルより長い場合、名前は切り捨てられます。

  • データソースが1つしかない場合、PyCharmはデータソース名をタブ名に表示しません。

  • 修飾オブジェクト名に36を超える記号がある場合、切り捨てられます。

Working with tables
トピックテーブルタスク
作成および削除テーブルを作成および削除する方法について説明します。
変更テーブル構造の変更方法、データベースとテーブルの説明の追加方法、テーブルの読み取り専用モードの有効化方法について説明します。
フィルターデータを表示するさまざまなモード、テーブルを転置する方法、エディターに表示されるデータをデータベースのコンテンツと同期する方法について説明します。
データを表示するデータを表示するさまざまなモード、テーブルを転置する方法、エディターに表示されるデータをデータベースのコンテンツと同期する方法について説明します。
比較2つのテーブル構造、または2つのテーブルの内容を比較する方法について説明します。

PostgreSQLの地理データにGeoビューアーを使用する

Geoビューアーは、データベース内の空間データを探索するために使用できるグラフィックビューアーです。サービスツールウィンドウでGeoビューアーが開きます。行をクリックしてマップ上の対応する領域に移動するか、マップ上のピンをクリックして対応する行に移動できます。

ジオビューアータブをサービスツールウィンドウから切り離すには、サービスツールウィンドウからドラッグします。

現在、PyCharmは次の形式の座標をサポートしています:WKT、WKB、およびPostGIS geometry4326

Geoビューアーで地理データを表示する

  1. データベースツールウィンドウ(表示 | ツール・ウィンドウ | データベース)で、地理データを含むテーブルをダブルクリックします。

  2. オプション・メニューの表示アイコン(Show Options Menu icon)をクリックし、地域ビューアーを表示を選択します。

  3. JCEFを有効にすることの潜在的なリスクに関する通知を参照してください。リスクを受け入れる場合は、JCEFを有効にするをクリックします。

  4. 再起動が必要ウィンドウで、今すぐ再起動をクリックします。

  5. 再起動後、Ctrl+F5 を押すか、地理的データを含むテーブルを再度開きます。

  6. オプション・メニューの表示アイコン(Show Options Menu icon)をクリックし、地域ビューアーを表示を選択します。

  7. View geographical data with the Geo viewer

JCEFを有効にした後にPyCharmを回復する

  1. configディレクトリに移動します。

    構文
    %HOMEPATH%\.<product><version>\config\projects
    サンプル
    C:\Users\JohnS\.PyCharm2020.2\config\projects
    構文
    ~/Library/Application Support/<product><version>
    サンプル
    ~/Library/Application Support/PyCharm2020.2
    構文
    ~/.<product><version>/config/plugins
    サンプル
    ~/.PyCharm2020.2/config/plugins
  2. オプションディレクトリで、ide.general.xmlをテキストエディターで開きます。

  3. 次の行を削除する: <entry key="ide.browser.jcef.enabled" value="true" />

最終更新日: 2020年9月07日

関連ページ:

データを表示する

以下は、データベース・ツールおよび SQLプラグインがインストールされ使用可能になっている場合にのみ有効です。データベースツールウィンドウ(表示 | ツール・ウィンドウ | データベース)でテーブルをダブルクリックすると、データエディターでテーブルが開きます。テーブルデータは、Table、ツリー、テ...

作成および削除

以下は、データベース・ツールおよび SQLプラグインがインストールされ使用可能になっている場合にのみ有効です。テーブルの作成データベースツールウィンドウで、データソースを選択してファイル | 新規 | テーブルに移動します。新しいテーブルを作成するダイアログで、テーブル設定(列、キー、インデックス、...

変更

以下は、データベース・ツールおよび SQLプラグインがインストールされ使用可能になっている場合にのみ有効です。テーブルを修正するデータベースツールウィンドウで、テーブルを右クリックしてテーブルの変更を選択します。テーブルの変更ダイアログで、必要なテーブル設定を指定します。データエディターからテーブル...

比較

以下は、データベース・ツールおよび SQLプラグインがインストールされ使用可能になっている場合にのみ有効です。2つのテーブル構造を比較して、列、キー、インデックス、およびその他の構造テーブル要素の違いを確認できます。また、選択したテーブルのデータを比較して、値の違いを確認することもできます。ダイアロ...

マイグレーションの実行

オブジェクトのソースコードの変更を確認したら、これらの変更をデータベースに送信できます。データベース変更ツールウィンドウでサブミットボタンを押すと、オブジェクトの移行ダイアログが表示されます。オブジェクトの移行ダイアログには、オブジェクトの移行スクリプトが表示されます。移行スクリプトは、すべてのデー...