PyCharm 2020.2ヘルプ

ソースコードで作業する

コードを使用する場合、PyCharmは作業にストレスがないことを保証します。追加、選択、コピー、移動、編集、折りたたみ、出現箇所の検索、コードの保存に役立つさまざまなショートカットと機能を提供します。

エディター内のナビゲーションについては、エディターの基本を参照してください。

アクションの検索

  • 使用したいアクションのショートカットを覚えていない場合は、Ctrl+Shift+A を押して名前でアクションを見つけてください。

同じダイアログを使用してクラス、ファイル、またはシンボルを見つけることができます。詳しくは、どこでも検索を参照してください。

新しいクラス、ファイル、パッケージ、またはスクラッチファイルを追加する

  • エディターで、Ctrl+Alt+Insert を押してクラス、ファイル、またはパッケージを追加します。

    フォーカスがプロジェクトツールウィンドウ内にあり、新しい要素を追加したい場合は、Alt+Insertを押します。

  • 新しいスクラッチファイルを作成するには、Ctrl+Alt+Shift+Insertを押します。

    PyCharmは実行してデバッグできる一時ファイルを作成します。詳しくは、スクラッチ・ファイルを参照してください。

ファイルの読み取り専用属性の切り替え

ファイルが読み取り専用の場合、ステータスバー、エディタータブ、またはプロジェクトツールウィンドウで、閉じた鍵のアイコン the Locked icon がマークされます。ファイルが書き込み可能である場合、ステータスバーに開いたロックアイコン the Unlocked icon が表示されます。

  1. ファイルをエディターで開くか、プロジェクトツールウィンドウで選択します。

  2. 以下のいずれか 1 つを実行します:

    • メインメニューからファイル | ファイルを読み取り専用にするまたはファイル | ファイルを書き込み可能にするを選択します。

    • ステータスバーのロックアイコンをクリックします。

バージョン管理システムによって読み取り専用ステータスが設定されている場合は、PyCharmバージョン管理統合機能を使用することをお勧めします。詳細は、バージョン管理を参照してください。

コード構成を選択する

  • エディターで、選択したい項目にキャレットを置き、Ctrl+W / Ctrl+Shift+W を押して選択を拡大または縮小します。

    例:プレーンテキストファイルでは、選択は単語全体から始まり、その後、文、段落などまで続きます。

  • 括弧を強調表示するだけの場合は、ブロック閉じ括弧/ 括弧の直後、またはブロック開き括弧/ 括弧の前にキャレットを置きます。

大文字と小文字を区別してコードを選択する

  1. 設定/環境設定ダイアログ Ctrl+Alt+Sで、エディター | 一般 | スマート・キーに移動します。

  2. " CamelHumps"を使用してください言葉チェックボックスを選択します。

大文字に応じて選択するときにダブルクリックを使用する場合は、設定/環境設定ダイアログ Ctrl+Alt+Sエディター | 一般ページでキャメルハンプ単語を適用する...チェックボックスが選択されていることを確認してください。

出現箇所を選択

ファイル内で選択した要素のすべての出現箇所をすばやく見つけたり、複数選択したり、次または前の出現箇所を選択したりできます。

  • ファイル内の出現箇所を複数選択するには、コードで必要な要素を選択してから Alt+Jを押します。同じキーを押して、次の出現箇所を見つけます。

    あるいは、Shift+Alt を押したまま、選択範囲に追加したいテキストをダブルクリックまたはドラッグします。

  • キャレットを次または前の出現位置に移動するには、それぞれ F3 または Shift+F3 を押します。

    F3を押すと、PyCharmは現在の出現箇所の選択を自動的に削除し、次の出現箇所を選択します。

  • ファイル内のすべての出現箇所を選択するには、Ctrl+Alt+Shift+Jを押します。

  • 選択した識別子の次または前の出現を見つけるには、Alt+Wheel up または Alt+Wheel downを押します。

タブとインデントを構成する

  1. 設定/環境設定ダイアログ Ctrl+Alt+S で、エディター | コード・スタイルに移動します。

  2. インデントを構成する言語を選択します。

  3. 右側のオプションから、タブとインデントで、Tabを押す、インデントする、またはコードを再フォーマットするときにエディターがタブを使用するためのタブ文字を使用を選択します。必要に応じてタブサイズを設定することもできます。このオプションを選択しない場合、PyCharmはスペースを使用します。

コードをコピーして貼り付ける

標準のショートカットを使用して Ctrl+C をコピーし、選択したコードフラグメントを Ctrl+V に貼り付けることができます。何も選択されていない場合、PyCharmはキャレットのある行全体を自動的にコピーします。

デフォルトでは、エディターで何かを貼り付けると、PyCharmは"スマート"を実行します。たとえば、コメントに複数の行を貼り付けると、貼り付けている行に適切なマーカーが自動的に追加されます。プレーンテキストのみを貼り付ける必要がある場合は、Ctrl+Alt+Shift+Vを押します。

  • キャレットを線または記号に置き、右クリックしてコンテキストメニューを開き、特殊コピー/貼り付け | 参照のコピーを選択します。参照のコピーCtrl+Alt+Shift+C)オプションを選択すると、PyCharmは、選択されたラインまたはシンボルのライン番号を含む参照文字列を作成します。 Ctrl+V を押すと、コピーした参照をどこにでも貼り付けることができます。

  • PyCharmは、クリップボードにコピーしたすべてのものを追跡します。履歴から貼り付けるには、エディターのコンテキストメニューから特殊コピー/貼り付け | 貼り付けCtrl+Shift+V)を選択します。開いたダイアログで、エントリを選択して貼り付けをクリックします。

    コードをコピーしてエディターに貼り付けると、PyCharmは、Unicode名の省略形で表される非表示(特殊)文字を表示します。

  • 参照を線またはシンボルにコピーできます。

    キャレットを特定のコード行に配置して Ctrl+Alt+Shift+C キーを押す(またはコンテキストメニューまたは編集メニューから参照のコピーを選択する)。PyCharmは、キャレットのあるシンボルに依存する形式で文字列を作成します。例:

    PythonメソッドのSolver.Solver.discr

    Pythonファイル用のSolver\Solver.py:14

コードの行

PyCharmはコード行を操作するための便利なショートカットをいくつか提供しています。

  • 現在の行の後に行を追加するには、Shift+Enterを押します。PyCharmはキャレットを次の行に移動します。

  • 現在の行の前に行を追加するには、Ctrl+Alt+Enterを押します。PyCharmはキャレットを前の行に移動します。

  • 行を複製するには、Ctrl+Dを押します。

  • ファイル全体またはコード選択で行をアルファベット順に並べ替えるには、メインメニューから編集 | 行のソートまたは編集 | 行の反転を選択します。これらのアクションは、プロパティファイル、データセット、テキストファイル、ログファイルなどを操作するときに役立つ場合があります。これらのアクションにショートカットを割り当てる必要がある場合、詳細についてはキーボードショートカットの構成を参照してください。

  • 行を削除するには、必要な行にキャレットを置き、Ctrl+Yを押します。

  • 行を結合するには、他の行を結合したい行にキャレットを置き、Ctrl+Shift+Jを押します。必要な要素がすべて結合されるまでキーを押し続けます。

    文字列リテラル、フィールドまたは変数の宣言、および文を結合することもできます。PyCharmはコードスタイル設定をチェックし、不要なスペースと余分な文字を削除します。

  • 文字列リテラルを2つの部分に分割するには、Enterを押します。

    PyCharmは文字列を分割して正しい構文を提供します。文字列を '\n' で区切る インテンションを使用して文字列リテラルを分割することもできます。 Alt+Enter を押すか、the Intention action button をクリックしてこのインテンションを選択します。

  • コード行をコメントにするには、キャレットを適切な行に置き、Ctrl+/を押します。

  • 行を上下に移動するには、それぞれ Alt+Shift+Up または Alt+Shift+Down を押します。

  • コード要素を左または右に移動(スワップ)するには、キャレットをその位置に置くか、キャレットを選択して左に Ctrl+Alt+Shift+Left または右に Ctrl+Alt+Shift+Right を押します。

コード文

移動ステートメント

  • エディターで、必要な文にキャレットを置き、文を上に移動するには Ctrl+Shift+Up を、文を下に移動するには Ctrl+Shift+Down を押します。PyCharmは、構文チェックを実行している選択されたステートメントを移動します。

現在のステートメントの補完

  • エディターで Ctrl+Shift+Enter を押すか、メインメニューからコード | 現在のステートメントの補完を選択します。PyCharmは、必要な末尾のコンマを構造体、スライス、およびその他の複合リテラルに自動的に挿入します。キャレットは、次のステートメントの入力を開始できる位置に移動します。

ステートメントのラップ解除または削除

  1. 削除または展開したい式にキャレットを置きます。

  2. Ctrl+Shift+Deleteを押します。

    PyCharmは、現在のコンテキストで利用可能なすべてのアクションを含むポップアップを表示します。抽出されるステートメントと削除されるステートメントを区別しやすくするために、PyCharmは異なる背景色を使用しています。

    Select a statement to unwrap
  3. 動作を選択して Enterを押します。

    Unwrapping result

コードフラグメント

  • コードフラグメントをエディターでドラッグして移動し、コピーします。

    • コードフラグメントを移動するには、それを選択して選択範囲を目的の場所にドラッグします。

    • Ctrl を押したままコード選択をコピーするには、それを目的の位置までドラッグします。

    ドラッグ機能はデフォルトで有効になっています。無効にするには、設定/環境設定ダイアログ Ctrl+Alt+Sエディター | 一般に移動し、マウス動作の詳細セクションのエディター内でドラッグ & ドロップを使用可能にするチェックボックスをオフにします。

  • 選択したコードフラグメントの大文字と小文字を切り替えるには、Ctrl+Shift+Uを押します。

    大文字と小文字の切り替えアクションをCamelCaseの名前形式に適用すると、PyCharmは名前を小文字に変換します。

  • コードの一部をコメントまたはコメント解除するには、それを選択して Ctrl+Shift+/を押します。

    コメント動作の設定を行うには、ファイル | 設定/環境設定 | エディター | コード・スタイル の言語固有のページにあるコード生成タブのコードのコメントセクションのオプションを使用します。

マルチ・キャレット

複数の行を同時に編集できます。例:複数の行にコメントマーカーを追加したり、単語のいくつかの出現箇所の一部の文字を削除したりできます。

  • 複数のキャレットを追加または削除するには、Alt を押しながらキャレットの次の位置をクリックします。

    あるいは、複数のキャレットを追加するには、Ctrl を2回押してから放さずに、Up または Down の矢印キーを押します。 Shift+Alt を押しながらキャレットをドラッグして複数選択することもできます。

  • 追加したキャレットをすべて削除するには、Escapeを押します。

  • 列で複数のコードを選択できます。列選択モードを有効または無効にするには、Alt+Shift+Insert を押すか、エディターのコンテキストメニューを使用します。

    このモードは、複数行のコードを同時に編集したい場合に役立ちます。必要な記号にキャレットを置いて上下にドラッグするか、コードブロックを選択して指定のショートカットを押すと同じ結果になります。

    Alt+↑/↓を押すと、キャレットの動きを変更できます。デフォルトの動作では、キャレットを現在の単語の末尾に移動します。この設定を変更するには、設定 Ctrl+Alt+S を開き、エディター | 一般に移動します。キャレットの移動セクションで、リストから適切な動作を選択します。

    Column selection mode

パラメーターのヒント

パラメーターのヒントは、コードを読みやすくするためのメソッドや関数のパラメータ名を示します。デフォルトでは、パラメータヒントは有効にされ、リテラルまたは関数式であるが名前付きオブジェクトではない値に対してのみ表示されます。

パラメータのヒントを設定する

  1. 設定/環境設定ダイアログ Ctrl+Alt+S を開き、エディター | インレイ・ヒント | <必要な言語>に進みます。

  2. リストからパラメーターのヒントを選択し、パラメーターのヒントの表示チェックボックスが選択されていることを確認してから、パラメーターヒントを表示するコンテキストを指定します。

  3. 一部のメソッドおよび関数では、PyCharmはどのコンテキストでもパラメーターヒントを表示しません。ブラックリスト...をクリックして、これらのメソッドと機能を表示したり、それらのパラメーターヒントを有効にしたり、リストに新しいアイテムを追加したりします。

コードの折りたたみ

折りたたまれたコードフラグメントは、影付きの省略記号(Folded fragment)として表示されます。折りたたまれたコードフラグメントにエラーが含まれている場合、PyCharmはフラグメントを赤で強調表示します。

デフォルトのコード折りたたみ動作を構成するには、設定/環境設定ダイアログ Ctrl+Alt+Sエディター | 一般 | コード折りたたみに進みます。

コード要素を展開または折りたたむ

  • コードの一部を折りたたむ、または展開するには、Ctrl+NumPad - / Ctrl+NumPad +を押します。PyCharmは、現在のコードの一部を折りたたむか展開します。たとえば、単一のメソッドです。

  • すべてのコードを折りたたむか展開するには、Ctrl+Shift+NumPad - / Ctrl+Shift+NumPad +を押します。

    PyCharmは、選択範囲内のすべてのフラグメントを折りたたむか展開します。何も選択されていない場合は、現在のファイル内のすべてのフラグメント(ファイル内のすべてのメソッドなど)を折りたたみまたは展開します。

  • 再帰的にコードを折りたたむか展開するには、Ctrl+Alt+NumPad - / Ctrl+Alt+NumPad +を押します。PyCharmは、現在のフラグメントとそのフラグメント内のすべての下位領域を縮小または拡大します。

  • コードのブロックを折りたたむには、Ctrl+Shift+.を押します。このアクションは、一致する波括弧 {}のペア間のコードフラグメントを折りたたみ、そのフラグメントのカスタム折りたたみ領域を作成して、「折りたたみ可能」にします。

  • 現在のファイルのdocコメントを折りたたむか展開するには、メインメニューでコード | 折りたたみ | ドキュメントのコメントを展開/ドキュメントのコメントを折りたたむを選択します。

  • カスタムコード選択を縮小または拡大するには、Ctrl+.を押します。

    手動で選択した領域をコード内で折りたたんだり展開したりできます。

入れ子になったフラグメントの折りたたみまたは展開

  • 現在のフラグメントとネストしたすべてのフラグメントを拡張するには、Ctrl+NumPad *, 1を押します。現在のフラグメントを指定されたネストレベル(1から5)まで拡張できます。

  • ファイル内のすべての折りたたまれたフラグメントを展開するには、Ctrl+Shift+NumPad *, 1を押します。折りたたまれたフラグメントを指定されたネストレベル(1から5まで)まで拡張できます。

囲むアクションを使う

囲むアクションを使用してコードを折りたたんだり展開したりできます。

  1. エディターで、コードの一部を選択して Ctrl+Alt+Tを押します。

  2. ポップアップメニューで、<editor-fold ...>コメントまたはregion ... endregionコメントを選択します。

  3. 必要に応じて、カスタムリージョンに名前を付け、作成されたリージョンを通常どおり Ctrl+NumPad - / Ctrl+NumPad +として折りたたみまたは展開します。

  4. 作成したカスタムリージョンに移動するには、Ctrl+Alt+. を押します。

コード折りたたみアウトラインを無効にする

左側のガターに表示されるコードの折りたたみアウトラインを無効にすることができます。

  1. 設定/環境設定ダイアログ Ctrl+Alt+Sで、エディター | 一般 | コード折りたたみに移動します。

  2. コードの折りたたみアウトラインを表示するチェックボックスをクリアします。

自動保存

PyCharmは自動的にあなたのファイルに加える変更を保存します。保存は、コンパイル、実行、デバッグ、バージョン管理操作の実行、ファイルやプロジェクトのクローズ、IDEの終了など、さまざまなイベントによって引き起こされます。実際のイベントの大部分は事前定義されているため設定できませんが、作業中に変更内容が失われないようにすることができます。

自動保存動作を設定する

  1. 設定/環境設定ダイアログ Ctrl+Alt+Sで、外観および振る舞い | システム設定に移動します。

  2. 自動保存で、次のオプションを設定します。

    • 別のアプリケーションに切り替えるときにファイルを保存する

    • ファイルを保存すると、IDEはN秒間アイドル状態になります。

バージョン管理統合を使用する場合、変更されたすべてのファイルの名前は、ファイルタブで専用の色でマークされます。ただし、ファイルタブで未保存のファイルにアスタリスク(*)を付けることもできます。

未保存の変更があるファイルにマークを付ける

  1. 設定/環境設定ダイアログ Ctrl+Alt+Sで、エディター | 一般 | エディター・タブに移動します。

  2. 変更したタブをアスタリスク (*) でマークするチェックボックスを選択します。

変更を元に戻す

  • 最新の変更については、Ctrl+Z を押すか、メニューから編集 | 元に戻すを選択します。

  • 過去の変更の詳細を表示するには、ローカル・ヒストリーを使用します。

  • すべての変更を最も確実に追跡するには、バージョン管理システムを使用します。

最終更新日: 2020年9月15日

関連ページ:

エディターの基本

PyCharmエディターは、コードの作成、読み取り、変更に使用するIDEの主要部分です。エディターは次の領域で構成されています。スクロールバーは現在のファイルのエラーと警告を表示します。パンくずリストは、現在のファイルのコード内を移動できます。ガターには、行番号と注釈が表示されます。タブには、現在開...

どこでも検索

プロジェクト内またはその外側にある項目をその名前で見つけることができます。ファイル、アクション、クラス、シンボル、設定、およびUI要素を単一のエントリポイントから検索できます。プロジェクト内のターゲットを検索および置換するまたはファイル内のターゲットを検索するからのテキスト検索について学びます。どこ...

スクラッチ・ファイル

場合によっては、一時的なメモを作成するか、プロジェクトコンテキストの外でコードを作成する必要があります。この目的で別のアプリケーションに切り替える代わりに、スクラッチファイルとスクラッチバッファーを使用できます。スクラッチ・ファイルは完全に機能する実行可能なファイルであり、構文の強調表示、コード補完...

ユーザーインターフェースの概要

PyCharmでプロジェクトを開くと、デフォルトのユーザーインターフェースは次のようになります。プラグインのセット、PyCharmエディション、および構成設定によっては、IDEの外観と動作が異なる場合があります。エディター:フォーカス:エディターを使用して、ソースコードの読み取り、書き込み、探索を行...

プロジェクトツールウィンドウ

このツールウィンドウを使用すると、プロジェクトをさまざまな観点から見て、新しい項目(ディレクトリ、ファイル、クラスなど)の作成、エディターでのファイルの開き、目的のコードフラグメントへの移動などのタスクを実行できます。このツールウィンドウのほとんどの機能には、コンテンツペインのコンテキストメニューコ...

バージョン管理

VCS 操作のポップアップ( またはVCS | VCS 操作のポップアップ)を使用すると、VCS関連のコマンドをすばやく呼び出すことができます。ポップアップ内のアクションのリストは、現在有効になっているVCSによって異なります。VCSオペレーションポップアップコマンドのリストは設定可能です。設定/環...