PyCharm 2020.2 ヘルプ

ソースコードの階層

PyCharm を使用すると、階層ツールウィンドウでクラス、メソッド、呼び出しの階層を調べ、構造ツールウィンドウでソースファイルの構造を調べることができます。

  • 階層および構造ツールウィンドウは、表示メニューから使用できます。

  • 階層ツールウィンドウは、階層が作成されたときにのみ使用可能になります。

  • 階層はナビゲートメニューに組み込まれています。

本パート :

    PyCharm を使用すると、クラス、メソッド、および呼び出しの階層を調べ、ソースファイルの構造を調べることができます。

    階層を構築する

    • タイプ階層は、クラスの親クラスと子クラスを示します。

    • 呼び出し階層は、メソッドの呼び出し元(スーパータイプ)または呼び出し先(サブタイプ)を示します。

    構築すると、階層ツールウィンドウで階層をすぐに表示して調べることができます。デフォルトでは、新しく構築された階層はすべて現在のタブの内容を上書きします。現在のタブを保持し、次の階層を新しいものに構築することができます。

    型階層を構築する

    1. プロジェクトツールウィンドウで目的のクラスを選択するか、エディターで開きます。

    2. メインメニューからナビゲート | 型階層を選択するか、単に Ctrl+H を押します。

      Class hierarchy shown in the Hierarchy Tool Window

    呼び出し階層を構築する

    1. エディターでファイルを開き、目的のメソッドの宣言または使用箇所にキャレットを置きます。

      または、プロジェクトツールウィンドウで目的の方法を選択します。

    2. メインメニューからナビゲート | 呼び出し階層を選択するか Ctrl+Alt+H を押します。

    階層タブを保持する

    • 階層ツールウィンドウで、ツールバーのタブをピン留めボタンPin buttonをクリックします。

    階層を表示する

    階層ツールウィンドウを開く

    1. 確認のための階層がすでに構築されていることを確認してください。上記の階層の構築を参照してください。

    2. メインメニューから表示 | ツールウィンドウ | 階層を選択します。

    タブ間を移動する

    • 現在表示されているタブをクリックして、リストから表示する次のタブを選択します。

    ビューの切り替え

    • PyCharm を使用すると、昇順または降順の階層、つまり、呼び出し先または呼び出し元のメソッド、親または子のクラスなどを構築および探索できます。

      the Caller Hierarchy toolbar button またはthe Callee Hierarchy toolbar buttonをクリックして、それぞれ呼び出し側メソッドまたは呼び出し先メソッドを表示します。

    階層ツールウィンドウのボタン

    項目 説明 使用可能な範囲
    the Class Hierarchy button

    選択したクラスの親クラスと子クラスの両方を表示します。これには、結果のツリーで矢印が付いています。

    クラス階層
    the Supertypes Hierarchy button 階層タイプに応じて:
    • クラス階層 : 現在のクラスの各スーパー型階層を示します。

    • 呼び出し階層 : 選択したメソッドの呼び出し元を表示します。

    クラス階層

    呼び出し階層

    the Subtypes Hierarchy button

    階層タイプに応じて:

    • クラス階層 : 選択したクラスを拡張するすべてのクラスを表示します。

    • 呼び出し階層 : 選択したメソッドの呼び出し先を表示します。

    クラス階層

    呼び出し階層

    the Sort Alphabetically button ツリー内のすべての要素をアルファベット順にソートします。 すべての階層
    スコープ

    このリストを使用して、現在の階層の範囲を制限します。

    • プロジェクト : プロジェクト全体でメソッドの使用状況を追跡します。

    • テスト : テストクラス全体でメソッドの使用状況をトレースします。

    • すべて : プロジェクトおよびライブラリ全体でメソッドの使用状況をトレースします。

    • このクラス : スコープを現在のクラスに制限します。

    事前構成されたスコープに加えて、独自のスコープを定義できます。スコープを定義するには、リストから構成を選択し、スコープダイアログで必要なスコープを定義します。

    呼び出し階層
    the Refresh button 更新されたすべてのクラスまたはクラス構造を表示します。 すべての階層
    the Navigate with Single Click button 階層ツリーの選択されたノードに対応するソースコード内のファイルとセクションに移動します。 すべての階層
    the Expand All button すべてのノードを展開します。 すべての階層
    the Pin button 現在のタブを閉じて再利用するのをロックします。次のコマンドの結果が新しいタブに表示されます。 すべての階層
    the Export to Text File 階層をテキストファイルにエクスポートします。このファイルの場所を指定できます。 すべての階層
    the Close button ツールウィンドウを閉じます。 すべての階層
    最終更新日 :