PyCharm 2020.3 ヘルプ

プロジェクトを開く、再開、閉じる

初めてプロジェクトを開くと、ウェルカム画面が表示されます。ディスクからプロジェクトを開くか、バージョン管理システムからダウンロードできます。

プロジェクトを開く

ディスクからプロジェクトを開く

  1. 以下のいずれか 1 つを実行します:

    • ウェルカム画面で、開くリンクをクリックします。

    • メインメニューからファイル | 開くを選択します。

  2. 開いたファイルまたはプロジェクトを開くダイアログで、目的のプロジェクトディレクトリの場所を見つけます。PyCharm プロジェクトは JB IDE project でマークされ、他の IDE または専用エディターで作成されたプロジェクトは a directory icon でマークされます。

    PyCharm 以外のディレクトリを選択すると、PyCharm は新しい IDE プロジェクト作成し、Python インタープリターをセットアップします。

  3. OK をクリックします。

Git からプロジェクトを開く

  1. 以下のいずれか 1 つを実行します:

    • ウェルカム画面で、バージョン管理から取得リンクをクリックします。

    • メインメニューから VCS | バージョン管理から取得を選択します。

  2. プロジェクトが保存されているバージョン管理システムを選択します。ここに Git があります:

    Open a project from VCS

  3. リポジトリへのパスを指定し、プロジェクトのクローンを作成するディレクトリを選択します。または、左側で GitHub を選択し、資格情報を使用してログインし、使用するプロジェクトを選択できます。

  4. クローンをクリックします。

コマンドラインからプロジェクトを開く

プロジェクトを開いたら、Python インタープリター構成して(特に、仮想環境を作成して)、プロジェクトセットアップする必要があります

プロジェクトが以前に現在利用できないインタープリターで構成されている場合、PyCharm は警告を表示し、2 つのオプションを提供します: 前の構成に適合するインタープリターを選択するか、別の Python インタープリターを構成します。

A warning message with the options to configure a project interpreter

古いバージョンの Python インタープリター用に構成されたプロジェクトを開くと、次のメッセージが表示されることに注意してください。notification on the unsupported version of the Python interpreter Python インタープリターを構成するをクリックして有効なものをセットアップします。

現在開いているプロジェクト(プライマリプロジェクト)に追加されているプロジェクトを閉じることができます。

複数のプロジェクトの管理

PyCharm は、複数のプロジェクトを同時に処理するための以下のオプションを提案しています。

  • 各プロジェクトは独自のウィンドウで開きます。プロジェクトは独立しており、クリップボード操作以外の情報は共有できません。すべてのプロジェクトは PyCharm の同じインスタンスで実行され、同じメモリ空間を使用します。

  • 新しく開いたプロジェクトは、すでに開いているプロジェクトと同じウィンドウを共有します。すでに開かれているプロジェクトはプライマリプロジェクトと見なされ、常にプロジェクトツールウィンドウの最初に表示されます。他のすべてのプロジェクトは、プライマリプロジェクトに追加されます。

    依存プロジェクトからクラスとメソッドをインポートできます。依存関係プロジェクト設定を使用して、この動作を構成します。

    一部の設定(DjangoBuildoutGoogle App Engineテンプレート言語Python インタープリターコンテンツルートなど)は、プロジェクトごとに個別に構成できます。

複数のプロジェクトを開く

  • プロジェクトを開く、もう 1 つはすでに開かれています。

    次に、設定 / 環境設定ダイアログ Ctrl+Alt+Sシステム設定ページのプロジェクトのオープン時セクションで選択されたオプションに応じて、以下が発生します。

    • 新しいウィンドウでプロジェクトを開くオプションが選択されている場合、新しいプロジェクトは新しいウィンドウで静かに開きます。プロジェクトの接続オプションがファイルメニューに表示されます。

    • 同じウィンドウでプロジェクトを開くオプションが選択されている場合、新しいプロジェクトは同じウィンドウに静かに開き、現在開いているプロジェクトを置き換えます。プロジェクトの接続コマンドがファイルメニューに表示されます。

    • プロジェクトを開くウィンドウを確認するオプションが選択されている場合、PyCharm は、プロジェクトを新しいウィンドウで開くか、既存のウィンドウを再利用するか、または現在開いているプロジェクトに新しいプロジェクトをアタッチするかを選択するよう求めます。すでに開かれているプロジェクト主要プロジェクトです。

      Open the project in the current window, new window, or attach it to the existing project

現在開いているプロジェクト(プライマリプロジェクト)に追加されているプロジェクトを閉じることができます。

ビューからプロジェクトを削除する

  1. プロジェクトツールウィンドウで、削除するプロジェクトを右クリックします。

  2. 選択のコンテキストメニューからプロジェクトビューから除去を選択するか、Delete を押します。

    Remove from the project view

PyCharm が開始されると、最新のプロジェクトがデフォルトで再度開きます(設定 / 環境設定ダイアログ Ctrl+Alt+Sシステム設定ページでこのオプションが無効にされていない限り)。

最近のプロジェクトの再開

PyCharm は最近のプロジェクトの履歴リストを保持しており、そこから目的のものを選択することができます。

PyCharm が開始されると、最新のプロジェクトがデフォルトで再度開きます(設定 / 環境設定ダイアログ Ctrl+Alt+Sシステム設定ページでこのオプションが無効にされていない限り)。

最近のプロジェクトを開く

  • メインメニューからファイル | 最近使用したものを開くを呼び出し、リストから目的のプロジェクトを選択します。

    このリストには、1 つのウィンドウを共有するプロジェクトも含まれています。

    プロジェクトを新しい %frame% で開くか、現在の %frame% を再利用するか、現在開いているプロジェクトにアタッチするかを指定します。

    Open the project in the current window, new window, or attach it to the existing project
  • ウェルカム画面で、左側のペインのプロジェクトをクリックし、最近のプロジェクトのリストが表示されている右側のペインで目的のプロジェクトを選択します。プロジェクトの検索フィールドへの入力を開始して、最近のプロジェクトのリストをフィルタリングします。

プロジェクトを閉じる

開いているプロジェクトが 1 つだけで、それを閉じると、PyCharm はウェルカム画面を表示します。複数のプロジェクトの場合、各プロジェクトはフレームで閉じられます。

プロジェクトを閉じる

  • プロジェクトを閉じるには、メインメニューからファイル | プロジェクトを閉じるを選択します。

最近のプロジェクトのリストからプロジェクトを削除する

  • ファイルメニューの最近使用したものを開くをクリックし、最近のプロジェクトリストの一番下にあるプロジェクトの管理をクリックします。

  • 削除するプロジェクトの終了アイコンをクリックします。

    Remove a recent project from the list of the recent projects
    選択したプロジェクトは、プロジェクトウィンドウとウェルカム画面の最近のプロジェクトのリストから削除されます。

ウェルカム画面のリストからのみプロジェクトを削除するには、対象プロジェクトを右クリックし、ウェルカム画面から選択を除去を選択します。

Remove a project from the list of the recent projects on the Welcome Screen

プロジェクト間の切り替え

開いているプロジェクトを切り替えるには、ウィンドウメニューの次のコマンドを使用します。

  • ウィンドウ | 次のプロジェクトウィンドウ Ctrl+Alt+]

  • ウィンドウ | 前のプロジェクトウィンドウ Ctrl+Alt+[

  • ウィンドウ | <ProjectNameOrLocation>

関連ページ:

ウェルカム画面

PyCharm は、プロジェクトが開かれていないときにウェルカム画面を表示します。例: PyCharm を初めて実行するとき、またはプロジェクトの唯一開いているインスタンスを閉じるとき。この画面から、新しいプロジェクトを作成したり、PyCharm Edu でパスの学習を開始したり、インポートしたり、開いたり、バージョン管理から既存のプロジェクトをチェックアウトしたりできます。カスタマイズタブを使用して作業環境を構成し、プラグインタブを使用して IDE プラグインを管理します。PyCharm を学ぶタ...

パス選択ダイアログ

このダイアログを使用して、さまざまな状況でファイルまたはフォルダーの場所を指定します。たとえば、実行する実行可能ファイル、使用する構成ファイル、テストまたはインスペクション結果をエクスポートするファイルなどを指定します。ダイアログ名と使用可能な機能は、現在実行しているタスクによって異なります(通常、不適切な機能は無効になっています)。例: 状況に応じて、1 つのアイテムのみ、またはいくつかのアイテムを選択できる場合があります。1 つまたは複数のフォルダーを選択できるが、1 つまたは複数のファイル...

Python インタープリターを構成する

PyCharm の Python インタープリター:PyCharm で Python コードを使用するには、少なくとも 1 つのインタープリターを構成する必要があります。Python インタープリターを 1 つだけ使用することに限定されません。いくつかを実装することができます。その際、特定のプロジェクトに使用するインタープリターを選択します。Python インタープリターを構成するときは、システム内の Python 実行可能ファイルへのパスを指定する必要があります。Python インタープリター...

PyCharm でプロジェクトを構成する

PyCharm で行うことは何でも、プロジェクトのコンテキストで行います。プロジェクトは、完全なソフトウェアソリューションを表す組織単位です。これは、コーディング支援、一括リファクタリング、コーディングスタイルの一貫性などの基礎として機能します。プロジェクトファイル:PyCharm のプロジェクトはディレクトリベースのフォーマットで表現されています。プロジェクトディレクトリにアイコンが表示されます。このようなプロジェクトディレクトリには、次のファイルを含む .idea ディレクトリが含まれています...

Django

このページを使用して、同じウィンドウで開いたプロジェクトごとに Django のサポートを構成します。プロジェクトこのペインには、同じウィンドウで開かれたプロジェクトのリストが表示されます。リストの最初のプロジェクトがプライマリプロジェクトです。Django サポートペイン:Django サポートを使用可能にするこのチェックボックスのデフォルトの状態は、プロジェクトの種類によって異なります。空のプロジェクトの場合、Django サポートは無効になっています。Django プロジェクトの場合、デフ...

プロジェクトツールウィンドウ

プロジェクトツールウィンドウでは、様々な視点からプロジェクトを見て、新しいアイテム(ディレクトリ、ファイル、クラスなど)の作成、エディターでのファイルのオープン、必要なコードフラグメントへのナビゲートなど、様々なタスクを実行することができます。このツールウィンドウのほとんどの機能には、コンテンツペインのコンテキストメニューコマンドとして、関連するショートカットを介してアクセスします。また、ビューには、作成されたスクラッチファイル、データベースコンソール、および拡張スクリプトを管理できるスクラッチ...