PyCharm 2020.1ヘルプ

外部ツール

スタンドアロンのサードパーティアプリケーションを外部ツールとして定義し、PyCharmから実行できます。

プロジェクトからコンテキスト情報をコマンドライン引数(たとえば、現在選択されているファイル、開いているファイル、プロジェクトのソースパスなど)として外部ツールに渡したり、ツールによって生成された出力を表示したり、実行/デバッグ構成などの前にツールを使用します。

PyCharmで使用できるさまざまな種類の外部ツールがあります。

  • ローカル外部ツールはあなたのマシン上でローカルに動作するアプリケーションです。

  • リモート SSH 外部ツールはSSHを介してリモートサーバー上で実行されます。

追加されたローカル外部ツールを実行する

選択したクラスファイルに対して追加した javap ツールを実行するには、次のいずれかを実行します。

  • メインメニューからツール | JDK | ジャバップを選択します。

  • プロジェクトツールウィンドウでファイルを右クリックして、コンテキストメニューからJDK | ジャバップを選択します。

  • 設定/環境設定ダイアログ Ctrl+Alt+Sキーマップを選択し、外部ツールノードでアクションを見つけて、ショートカットを割り当てます。ショートカットを使用してツールを実行します。

ツールが実行されると、その出力が実行ツールウィンドウに表示されます。

Running External Tool

ローカル外部ツールを追加する

pylintは、コードをチェックしてスタイル、ロジック、および使用上の問題を検出するコードアナライザツールです。PyCharmで利用可能なコード検証機能への素晴らしい追加かもしれません。

  1. 設定/環境設定ダイアログ Ctrl+Alt+Sで、プロジェクト | プロジェクト・インタープリターを選択します。

  2. 新しいパッケージをインストールするには、 add a package をクリックしてください。

  3. 使用可能なパッケージウィンドウで、「pylint」を検索し、パッケージのリストでそれを選択し、パッケージのインストールをクリックします。

    pylint installation

    パッケージがインストールされるまで待ち、ウィンドウを閉じます。

  4. システムにpylintをインストールしたため、PyCharmとの統合を設定できます。

    設定/環境設定ダイアログで、Ctrl+Alt+Sツール | 外部ツールにナビゲートします。

  5. 新しい外部ツールを追加するには、add an external tool ボタンをクリックします。

  6. 次のように設定オプションを追加します。

    Configure pylint as an external tool
    • グループ : ツール | 外部ツール メニューに表示する外部ツールグループの名前

    • 名前 : 外部ツール名

    • 説明 : オプションの説明

    • プログラム : Pylint実行可能ファイルへのパス($PyInterpreterDirectory$ は現在のプロジェクトのPythonインタープリターが置かれているディレクトリです)。
      例:

      $PyInterpreterDirectory$\pylint
      $PyInterpreterDirectory$/pylint (Linux、macOS)

    • 引数 : どのファイルとフォルダーをチェックするか(この例ではcar.pytest )を指定し、Pylintエラーの出力フォーマットを設定します。
      例:

      --msg-template="$FileDir$\{path}:{line}:{column}:{C}:({symbol}){msg}" car.py test
      --msg-template="$FileDir$/{path}:{line}:{column}:{C}:({symbol}){msg}" car.py test

    • 作業ディレクトリ : プロジェクト・ルート・ディレクトリ

    • 拡張オプションセクションのすべてのオプションを有効にして、エラーのあるファイルへのリンクをpylint出力に挿入するように出力フィルターを設定すると、コード内のエラーや警告にすばやくジャンプできます。

  7. 変更を保存するには、OKをクリックします。外部ツールウィンドウで 適用 OKをクリックして外部ツールを追加します。

これでツール | 外部ツールからこの外部ツールにアクセスできます。

pylint is shown in the External Tools menu

このメニューを使用してpylintを実行できます。ただし、アプリケーションの実行/デバッグ構成 に追加することもできます。

外部ツールを実行する

  1. メインメニューから実行 | 構成の編集を選択し、構成の編集ダイアログで起動前セクションの Run pylint before start をクリックします。

  2. 新規構成の追加リストから外部ツールの実行を選択し、pylintを指定します。アプリケーションの起動前に実行されるスクリプトのリストに追加されます。

    Adding pylint to the Run/Debug configuration
  3. 変更を保存するには、OKをクリックします。

  4. 実行/デバッグ構成 Shift+F10を実行します。

    Run the script

    ツールウィンドウには、次のサンプル出力を含むpylintタブが表示されます。

    code validation with pylint

報告されたエラーをインスペクションし、対応するリンクをクリックして問題のあるコードに移動し、必要な変更を加えることができます。

リモート SSH外部ツールを追加する

リモート SSH外部ツールはローカルの外部ツールと同様に設定されていますが、それらが実行されるリモートサーバーも定義しており、SSH経由で接続するための認証情報が必要です。

この例では、リモートサーバー上で実行され、現在の日時を返すリモート SSH外部ツールとして date を追加する方法を示します。

  1. 設定/環境設定ダイアログ Ctrl+Alt+Sで、ツール | リモート SSH 外部ツールを選択します。

  2. the Add button をクリックして、以下の設定を指定します。

    The Create Tool dialog

    このダイアログでは、ローカル外部ツールを追加する場合と同じ設定セットが提供されますが、リモートサーバーを選択することも推奨されます。これは、構成済みのSSH構成またはVagrantボックスのいずれかです。デフォルトでは、PyCharmは、サーバーでツールを実行するたびに、ホスト、ポート、および関連するSSH認証情報を要求します。

  3. OKをクリックしてツールを追加してから変更を適用します。

追加されたツールをリモートサーバーで実行する

  • メインメニューからツール | リモートツール | 日時を選択します。

  • 設定/環境設定ダイアログ Ctrl+Alt+Sキーマップを選択し、Date and time アクションを見つけて、それにショートカットを割り当てます。ショートカットを使用してツールを実行します。

ホスト、ポート、および資格情報を指定した後、PyCharmはSSH経由でサーバーに接続して date コマンドを実行し、PyCharmの実行ツールウィンドウに出力を返します。

Web ブラウザー

Webブラウザを使用してプロジェクトから任意のファイルを開くことができますが、通常はHTMLファイルの出力をプレビューしたり、Webアプリケーションを実行したりデバッグしたりするために使用されます。

Webブラウザでファイルを開く

Webブラウザー(HTML、XML、JSPなど)によってレンダリングされることを意図したファイルを開くには、次のいずれかを実行します。

  • Alt+F2を押します。

  • ファイルを右クリックしてブラウザーで開くを選択します。

  • メインメニューから表示 | ブラウザーで開くを選択します。

  • エディターウィンドウの右上にあるブラウザのポップアップを使用してください。ブラウザボタンをクリックしてWebサーバーファイルのURLを開くか、または Shift+Click をクリックしてローカルファイルのURLを開きます。

    The Browser popup in the editor

ブラウザーで開くアクションは、他のファイルタイプでは使用できません。ただし、アクションの検索 Ctrl+Shift+Aを使用して実行することはできます。

PyCharmはデフォルトで、いくつかの最も人気のあるブラウザーをサポートします。これらのブラウザーは、可能な場合は自動的に構成されます。

  • Chrome Chrome browser icon

  • Firefox Firefox browser icon

  • Safari Safari browser icon

  • Opera Opera browser icon

  • Internet Explorer Internet Explorer browser icon

  • エッジ Edge browser icon

ブラウザーのリストを表示および構成する

  • 設定/環境設定ダイアログ Ctrl+Alt+Sで、ツール | Web ブラウザーを選択します。

The Web Browsers page in Preferences

標準の手順を使用してブラウザをインストールした場合は、パスフィールドのエイリアスが正しい場所を指しているはずです。そうでない場合は、対応する実行可能ファイルへのパスを指定します。

リスト内のブラウザの順序は、ポップアップ、コンテキストメニュー、および表示メニューの順序に対応しています。ブラウザを無効にすると、ポップアップ、コンテキストメニュー、および表示メニューに表示されません。

カスタムブラウザを追加する

  1. 設定/環境設定ダイアログ Ctrl+Alt+Sで、ツール | Web ブラウザーを選択します。

  2. the Add button をクリックして、ブラウザ名、ファミリ、および実行可能ファイルまたはmacOSアプリケーションの場所を指定します。

デフォルトのブラウザを選択

表示メニューおよびファイルのコンテキストメニューのブラウザーで開く項目には、利用可能なすべてのブラウザとデフォルトのブラウザが一覧表示されます。これらは外部リソースのレンダリングにも使用されます。

  1. 設定/環境設定ダイアログ Ctrl+Alt+Sで、ツール | Web ブラウザーを選択します。

  2. デフォルト・ブラウザーリストから、以下のいずれかを選択します。

    • システム・デフォルト : お使いのオペレーティングシステム用のデフォルトブラウザを使用してください。

    • 最初にリストされた : リストの最初のブラウザを使用してください。

    • カスタムパス : リストにないブラウザを使用してください。実行ファイルの場所を指定します。

カスタムプロファイルと設定を使用する

FirefoxおよびChromeファミリーブラウザ用のカスタムプロファイルを設定できます。

  1. 設定/環境設定ダイアログ Ctrl+Alt+Sで、ツール | Web ブラウザーを選択します。

  2. リストからブラウザを選択して the Edit buttonをクリックします。

    • Firefoxの場合は、profiles.ini ファイルへのパスを指定し、使用するプロファイルを選択してください。詳しくは、Firefoxのブラウザプロファイル(英語)を参照してください。

    • Chromeの場合、カスタムユーザーデータディレクトリを使用するを選択し、ユーザーデータディレクトリ(英語)の場所を指定します。

      PyCharmからChromeを実行するときに使用する追加のコマンドラインオプションを指定することもできます。詳細については、Chromeアドレスバーの chrome://flags を開いてください。

最終更新日: 2020年5月25日

関連ページ:

パッケージのインストール、アンインストール、およびアップグレード

PyCharmは、特定のPythonインタープリター用にPythonパッケージをインストール、アンインストール、およびアップグレードするための方法を提供します。デフォルトでは、PyCharmはプロジェクトパッケージの管理にpipを使用します。Conda環境では、condaパッケージマネージャーを使う...

実行/デバッグ構成: Python

初めてアプリケーションを実行すると、PyCharmは自動的に一時的な実行/デバッグ構成を作成します。デフォルトのパラメータを指定または変更して永続的な実行/デバッグ構成として保存するように変更できます。前提条件:開始する前に、Pythonと関連するフレームワークがインストールされていることを確認して...

SSHターミナルを実行する

PyCharmからSSH セッションを起動することができます。専用のSSHターミナルでコマンドを実行することにより、リモート Webサーバーまたはデフォルトのリモートインタープリター上のデータにSSHトンネル経由でアクセスすることができます。主にファイルのアップロードとダウンロードが可能です。SSH...

ファイルタイプの関連付けを設定する

PyCharmで認識されないファイルタイプ(社内で開発された独自のファイルタイプなど)を使用している場合や、サポートされていない言語でコーディングする必要がある場合は、カスタムファイルタイプを作成できます。キーワード、コメント、数字などの強調表示スキームを定義することによって、IDEがファイルを解析...