PhpStorm 2024.1 ヘルプ

エディターの基本

PhpStorm エディターは、コードの作成、読み取り、変更に使用する IDE の主要部分です。

エディターは次の領域で構成されています。

Editor details
  1. スクロールバーは現在のファイルのエラーと警告を表示します。

  2. パンくずリストは、現在のファイルのコード内を移動できます。

  3. ガターには、行番号、アノテーション、コンテキスト依存のアクションアイコンが表示されます。

  4. タブには、現在開いているファイルの名前が表示されます。

ナビゲーション

さまざまなショートカットを使用して、エディターウィンドウとさまざまなツールウィンドウを切り替えたり、エディターサイズを変更したり、フォーカスを切り替えたり、元のレイアウトに戻ることができます。

エディターペインを最大化する

  • エディターで、Ctrl+Shift+F12 を押します。PhpStorm はアクティブなエディターを除くすべてのウィンドウを隠します。

    分割画面を最大化することもできます。この場合、アクティブな画面が最大化され、他の画面は脇に移動されます。

ウィンドウからエディターにフォーカスを切り替える

  • Escape を押す。PhpStorm はフォーカスを任意のウィンドウからアクティブなエディターに移動します。

コマンドラインターミナルからエディターに戻る

  • Alt+F12 を押す。PhpStorm はターミナルウィンドウを閉じます。

  • アクティブなエディターに戻ったときにターミナルウィンドウを開いたままにしておく必要がある場合は、Ctrl+Tab を押します。

最後のアクティブウィンドウに移動する

  • F12 を押します。

ナビゲーションにスイッチャーを使う

  1. 開いているファイルとツールウィンドウをスイッチャーで切り替えるには、Ctrl+Tab を押します。

  2. スイッチャーポップアップを開いたままにするには、Ctrl を押し続けます。

  3. 要素間を移動するには Tab を押します。選択したファイルをリストから削除してエディターで閉じるには、Backspace を押します。

IDE の外観を変更する

スキーム、キーマップ、表示モードを切り替えることができます。

  1. Ctrl+` を押します。

  2. 切り替えメニューで、必要なオプションを選択し、Enter を押します。同じショートカット Ctrl+` を使用して、変更を元に戻します。

設定 | エディター | カラースキームの切り替えでは、視力多様性のある人向けのハイコントラストカラースキームを含む、カラースキーム設定を調整できます。キーマップ設定を調整するには、設定 | キーマップに移動します。

  • Alt+Home を押します。

スクロールバー

エディターでコードを操作すると、PhpStorm は、エラーと警告を含むコード分析結果をスクロールバーに表示します。コードに問題があるかどうかを確認し、すばやくそれらに移動できます。

スクロールバーの上部には、コードの問題の簡単な概要を表示するインスペクションウィジェットがあります。ウィジェットをクリックすると、問題ツールウィンドウで検出された各問題に関する詳細情報が表示されます。

Code analysis summary

詳細は、現在のファイルの即時分析を参照してください。

スクロールバーの縞模様は、PhpStorm が問題を見つけた場所を示しています。ストライプの上にマウスを移動すると、問題を説明するツールチップが表示されます。または、ストライプをクリックして簡単にナビゲーションできます。

ファイルの作業中に多くの縞模様が表示されるのは通常のことです。これらのエラー、警告、提案の多くは、コードを完成させると最終的に解決されます。コードが完了したと思ったときにエラーが残っている場合は、プロジェクトをコンパイルする前にエラーを調査して解決することをお勧めします。

ストライプのさまざまな色の違いは、赤でマークされたエラーから青でマークされた TODO コメントまでの問題の重大度を示しますが、必要に応じて表示される色を変更できます。詳細については、「インスペクションの重大度を変更する」を参照してください。

固定行

固定行 (または固定スクロール ) 機能は、ファイルをスクロールするときに親要素の可視性を維持し、コードのコンテキストを即時に提供することで、コーディングエクスペリエンスを向上させます。

任意の固定行をクリックして、対応する宣言までエディターをスクロールすることもできます。

PhpStorm: Sticky lines in the editor

デフォルトでは、固定行の最大数は 5 に設定されています。

固定行の数を設定する

  • Ctrl+Alt+S を押して設定を開き、エディター | 一般 | 外観を選択します。

スクロール中に固定行を表示するチェックボックスの横に、必要な固定行の数を入力します。

デフォルトでは、固定行の表示機能は有効になっています。

固定行を無効にする

  • エディター内の固定行を右クリックし、固定行を無効にするをクリックします。

    Disable Sticky Lines
  • ガターを右クリックし、外観を選択してから、固定行の表示の選択を解除します。

  • Ctrl+Alt+S を押して設定を開き、エディター | 一般 | 外観を選択します。スクロール中に固定行を表示するチェックボックスをオフにします。

固定行の色設定を変更する

  • Ctrl+Alt+S を押して設定を開き、エディター | カラースキーム | 一般 | エディター | 固定行を選択します。背景、境界線、ホバー状態の色を編集します。

エディタータブ

エディタータブを閉じたり、隠したり、切り離したりできます。ファイルを編集用に開くたびに、その名前のタブがアクティブなエディタータブの横に追加されます。

エディターのタブを設定するには、設定 | エディター | 一般 | エディタータブページを使用します。または、タブを右クリックし、オプションのリストからエディタータブの構成を選択します。

タブを開くまたは閉じる

  • 開いているタブをすべて閉じるには、メインメニューからウィンドウ | エディタータブ | すべてのタブを閉じるを選択します。

  • 非アクティブなタブをすべて閉じるには、Alt を押してアクティブなタブの the Close button をクリックします。この場合、アクティブなタブだけが開いたままになります。

  • アクティブなタブと固定されたタブを除くすべてのタブを閉じるには、任意のタブを右クリックして他のタブを閉じるを選択します。

  • アクティブなタブだけを閉じるには、Ctrl+F4 を押します。タブ上の任意の場所でマウスのホイールボタンをクリックして閉じることもできます。

  • 閉じたタブを再度開くには、任意のタブを右クリックし、コンテキストメニューから閉じたタブを再度開くを選択します。

  • 新しいタブを開いて、開いているすべてのタブの右側に配置するには、タブ設定新しいタブを最後に追加するを選択します。

パスまたはファイル名をコピー

  1. タブを右クリックします。

  2. 表示されたリストからパス / 参照のコピーを選択します。

  3. 表示されるリストから、コピーオプションを選択します。

    Copy path

    PhpStorm は項目をクリップボードにコピーし、必要な場所に貼り付ける (Ctrl+V) ことができます。

タブを移動、削除、並べ替える

  • タブ上の the Close button アイコンを移動または削除するには、設定ダイアログ (Ctrl+Alt+S) でエディター | 一般 | エディタータブに移動し、閉じるボタンの位置フィールドで適切なオプションを選択します。

  • エディタータブをエディターフレームの別の部分に配置するか、タブを非表示にするには、タブを右クリックしてエディタータブの構成を選択し、エディタータブ設定を開きます。「外観」セクションで、「タブ配置」リストから適切なオプションを選択します。

  • 非表示のエディタータブを表示するには、エディターで最後に表示されているタブの横にある the Hidden tabs icon をクリックします。

  • エディタータブをアルファベット順にソートするには、タブを右クリックしてエディタータブの構成を選択してエディタータブ設定を開きます。タブの順序セクションで、タブをアルファベット順で並べ替えるを選択します。

タブの固定または固定解除

アクティブなエディターのタブを固定して、タブの制限に達したとき、または他のタブを閉じるコマンドを使用したときに開いたままにすることができます。

  • アクティブなタブを固定または固定解除するには、タブを右クリックして、コンテキストメニューからタブをピン留めまたはタブのピン留め解除を選択します。

  • タブをピン留めアクションのキーボードショートカットを割り当てるには、設定ダイアログ(Ctrl+Alt+S)でキーマップに移動し、アクティブなタブを固定アクションを見つけて右クリックし、キーボードショートカットの追加を選択して、使用するキーの組み合わせを押します。

  • 固定されたタブを左側に維持するには、設定ダイアログ (Ctrl+Alt+S) で詳細設定に移動し、エディタータブセクションを見つけて、ピン留めしたタブを左に保持するオプションを選択します。

タブを切り離す

タブを切り離すと、そのタブは別のウィンドウで開き、そのウィンドウは切り離されたタブ用に予約されます。

メインフレームから別のタブを切り離そうとすると、すでに切り離されているタブがウィンドウ内で開かれます。新しく切り離したタブを好きな場所 (左、右、下、または上) に配置できます。さまざまなツールウィンドウをそのフレームにドラッグすることもできます。

  • 必要なタブをメインウィンドウの外にドラッグします。タブを再度接続したい場合は、タブをメインウィンドウ上にドラッグして戻します。

  • アクティブなタブを切り離すには、Shift+F4 を押します。

  • 同じアクションに Alt+mouse を使用することもできます。

タブを切り替える

  • タブ間を移動するには、Alt+Right または Alt+Left を押します。

  • 最近表示したタブやファイルを切り替えることもできます。

    エディターで、Ctrl+Tab を押し、Ctrl を押したままにして、スイッチャーウィンドウを開いたままにします。Tab を使用して、必要なタブまたはファイルを選択します。

開いたタブにショートカットを割り当てる

  1. 設定ダイアログ(Ctrl+Alt+S)で、キーマップに移動します。

  2. ディレクトリのリストで、その他をクリックし、ショートカットを追加するディレクトリを選択します。ショートカットを割り当てられるタブの最大数は 9 です。

    Add shortcuts for tabs

デフォルトのタブ制限を変更する

PhpStorm は、エディターで同時に開くことができるタブの数を制限します (デフォルトのタブ制限は 10 です)。

  1. 設定ダイアログ(Ctrl+Alt+S)で、エディター | 一般 | エディタータブに移動します。

  2. 閉じるポリシーセクションで、好みに合わせて設定を調整し、OK をクリックします。

プレビュータブでファイルを開く

プレビュータブでは、新しいタブで各ファイルを開かなくても、1 つのタブでファイルを 1 つずつ表示できます。これは、タブの制限を超えずに複数のファイルを調べる必要がある場合に役立ちます。

  1. プロジェクトツールウィンドウ Alt+1 で、 をクリックし、プレビュータブの有効化を選択します。

    設定 | 一般 | エディタータブ | 開くポリシーでプレビュータブを有効にすることもできます。

  2. プロジェクトツールウィンドウで、他のタブでまだ開いていないファイルを選択します。

    ファイル名はプレビューモードを示すために斜体で書かれています。他のファイルを選択すると、プレビュータブの前のファイルが置き換えられます。

    ファイルの編集を開始するか、ファイルのタブをダブルクリックしてプレビューモードを終了し、プレビュータブを通常のタブに変換します。

    The preview tab

    プレビュータブが有効になっている場合、シングルクリックでファイルを開くオプションは無視されることに注意してください。ファイルをダブルクリックして、通常のタブで開きます。

スペースがない場合はタブを非表示にする

  1. Ctrl+Alt+S を押して設定を開き、エディター | 一般 | エディタータブを選択します。

  2. スペースがない場合はタブを非表示にするオプションを選択します。追加のタブは、エディターの右上にあるドロップダウンリスト (Show Hidden Tabs) に配置されます。

新しい UI で複数のタブを表示する

画面に収まらないほど多くのタブを開いた場合は、タブを 1 行または複数の行に配置できます。

  1. Ctrl+Alt+S を押して設定を開き、エディター | 一般 | エディタータブを選択します。

  2. タブを表示セクションで、次のいずれかのオプションを選択します。

    • 1 行、およびタブが収まらない場合 : すべてのタブを 1 行に配置し、タブが収まらない場合:

      • タブパネルのスクロール : タブ行の上にマウスを置き、表示されるスクロールバーまたはマウスホイールを使用してタブをスクロールします。あるいは、右側のドロップダウンリスト (Show Hidden Tabs) を使用して、ビューポートの外側にあるタブを開きます。

      • タブの縮小 : 画面に収まるようにタブを縮小します。

    • 複数行 : タブを数行に配置します。

    Scroll tabs
    Squeeze tabs
    Multiple rows

タブのフォントサイズを変更する

  1. 設定ダイアログ(Ctrl+Alt+S)で、外観 & 振る舞い | 外観に移動します。

  2. サイズフィールドでフォントサイズを指定し、OK をクリックして変更を保存します。

    フォントサイズはタブだけでなくツールウィンドウでも変更されることに注意してください。

画面を分割

PhpStorm には、メインメニューまたはコンテキストメニュー、エディター、プロジェクトツールウィンドウから呼び出してエディター画面を分割できるさまざまなアクションが用意されています。

  • エディターで、目的のエディタータブを右クリックし、エディターウィンドウを分割する方法(右に分割または下に分割)を選択します。PhpStorm はエディターの分割ビューを作成し、選択に従って配置します。

  • 代わりに、ウィンドウ | エディタータブおよび分割して右に移動または分割して下に移動オプションに進みます。

  • エディターを分割するためにタブを垂直または水平にドラッグし、画面を分割解除するためにタブをドラッグして戻すことができます。

    Drag-and-drop tab
  • 右側の分割部分にあるエディターでファイルを開くことができます。

    プロジェクトツールウィンドウでファイルを右クリックし、コンテキストメニューから右に分割して開くを選択します。PhpStorm は、エディターの右側の分割でファイルを開きます。

    Open in Right Split

    2 つの分割があり、フォーカスが左側の分割にある場合、ファイルは既存の右側の分割で開かれます。フォーカスが右分割にある場合、ファイルは次の右分割で開かれます。

  • 分割画面間でファイルを移動できます。エディターで必要なファイルタブを右クリックし、コンテキストメニューからエディターを反対のタブグループに移動または反対側で開くを選択します。

  • 開いているすべてのツールウィンドウを一度に閉じて、分割画面を拡大することができます。エディターのタブにキャレットを置き、Ctrl+Shift+F12 を押すか、タブをダブルクリックします。PhpStorm は開いているツールウィンドウをすべて非表示にするため、すべてのスペースが分割画面で共有されます。

  • ネストした分割の比率を揃えるオプションを使用すると、エディターを複数回均等に分割できます。

  • 画面の分割を解除するには、コンテキストメニューから分割しないまたは分割をすべて解除を選択して、分割されたすべてのフレームの分割を解除します。

分割画面を移動する

  1. キャレットを目的の分割フレーム内に配置します。

  2. メインメニューで、ウィンドウ | エディタータブに移動します。

  3. オプションのリストから、次のオプションのいずれかを選択します。

    • エディターを上に伸縮

    • エディターを左に伸縮

    • エディターを下に伸縮

    • エディターを右に伸縮

    各オプションにショートカットを割り当て、キーボードを使用して分割フレームを引き伸ばすことができます。

    分割フレーム間を移動するには、ウィンドウ | エディタータブに移動します。オプションのリストから、次の分割へ移動 ⌥⇥または前の分割に移動 ⌥⇧ ⇥をそれぞれ選択します。

フォント

フォント、そのサイズ、フォントの合字を構成および変更できます。フォントサイズの変更は、1 つのエディタータブのみに適用することも、グローバルに適用することもできます。

フォントとフォントの合字を構成する

  1. 設定ダイアログ(Ctrl+Alt+S)で、エディター | フォントに移動します。

  2. リストから目的のフォントを選択し、そのサイズおよび行の高さを指定します。合字を有効にしたり、タイポグラフィ設定を構成したりすることもできます。

  3. 変更を保存するには、OK をクリックします。

エディターからフォントサイズを変更する

  1. 設定ダイアログ(Ctrl+Alt+S)で、エディター | 一般マウスコントロールセクション)に移動します。

  2. Ctrl + マウスホイールでフォントサイズを変更するオプションを選択してください。

  3. エディターに戻り、Ctrl を押したままにして、マウスホイールを使用してフォントサイズを調整します。

すべてのタブのフォントサイズを拡大または縮小する

  • エディターで、Alt+Shift+. を押してフォントサイズを全体的に大きくし、Alt+Shift+Comma を押して小さくします。

    PhpStorm はエディターの下部にズームインジケーターを表示し、現在のフォントサイズとロールバックできるデフォルトのフォントサイズを示します。

  • ズームインジケーターはデフォルトで有効になっています。これを無効にするには、設定ダイアログ (Ctrl+Alt+S) を開き、詳細設定に移動し、エディターセクションのズームインジケーターの表示オプションをクリアします。

便利なエディター構成

設定ダイアログ (Ctrl+Alt+S) のエディターセクションを使用して、エディターの動作をカスタマイズできます。

editor settings

次の一般的な設定を確認してください。

コードフォーマットを設定する

  1. 設定ダイアログ(Ctrl+Alt+S)で、エディター | コードスタイルに移動します。

  2. 言語のリストから適切な言語を選択し、タブとインデント、スペース、折り返しと中括弧、ハードマージンとソフトマージンなどの設定を構成します。

さまざまな言語およびフレームワークの配色設定を構成する

  1. 設定ダイアログ(Ctrl+Alt+S)で、エディター | カラースキームの切り替えに移動します。

  2. カラースキームの切り替えノードを開き、必要な言語またはフレームワークを選択します。一般オプションを選択して、コード、エディター、エラーと警告、ポップアップとヒント、検索結果などの一般的な項目の配色設定を構成することもできます。

コード補完オプションを設定する

  • 設定ダイアログ (Ctrl+Alt+S) で、エディター | 一般 | コード補完に進みます。ここでは、大文字と小文字を区別する補完、自動表示オプション、コードの並べ替えなどを構成できます。

キャレットの配置を構成する

  • 設定ダイアログ (Ctrl+Alt+S) で、エディター | 一般に進みます。仮想スペースセクションで、キャレット配置オプションを構成します。

    前の行の終わりと同じ位置にある次の行にキャレットを配置するには、行末以降へのキャレット移動を許可するオプションを選択します。このオプションをオフにすると、次の行のキャレットは実際の行の末尾に配置されます。

    タブ文字内へのキャレット移動を許可するオプションを選択すると、ファイルを同じ位置に保ちながらキャレットをファイル内で上下に移動できます。

保存時の末尾スペースの動作を設定する

  • 設定ダイアログ (Ctrl+Alt+S) で、エディター | 一般に進みます。その他セクションで、末尾のスペースのオプションを構成します。

    例: 手動または自動でコードを保存し、保存時に行末のスペースを除去するリストでどのオプションが選択されているかに関係なく、キャレット行の末尾のスペースを保持したい場合は、キャレット行末尾の空白を保持するオプションを選択します。

エディターの外観オプションを設定する

  • 設定ダイアログ(Ctrl+Alt+S)で、エディター | 一般 | 外観に移動します。

    例: ハードラップガイドまたはパラメーターヒントを表示するように IDE を構成できます。

長い行の外観を管理する

  1. 設定ダイアログ(Ctrl+Alt+S)で、エディター | 一般に移動します。

  2. 行の折り返しセクションで、適切なオプションを指定します。

    例: ソフトラップを適用するファイルタイプを指定できます。マークダウンファイルでドキュメントを作成するときに役立ちます。

スマートキーを設定する

使用する言語に応じて、基本的なエディターのアクションの動作が異なるように構成できます。

  • 設定ダイアログ(Ctrl+Alt+S)で、エディター | 一般 | スマートキーに移動します。

    例: タブで閉じ括弧 / 引用符の外に移動するオプションを選択すると、右角括弧の外でのナビゲーションを有効にするか、コードを入力するときに Tab で引用符を付けることができます。

関連ページ:

ソースコードナビゲーション

さまざまなアクションやポップアップを使用して、エディター内のコードを素早く移動することができます。エディターウィンドウとツールウィンドウ間の移動に関する詳細情報については、エディターの基本を確認してください。PhpStorm で利用可能なナビゲーションオプションをチェックするためにビデオチュートリアルを見ることから始めることができます。キャレットで移動する後方に移動するには、を押します。前方に移動するには、を押します。最後に編集した場所に移動するには、を押します。エディターで現在のキャレッ

プラグインのインストール

プラグインは PhpStorm のコア機能を拡張します。例: プラグインをインストールして、次の機能を取得します。バージョン管理システム、課題追跡システム、ビルド管理サーバー、その他のツールとの統合。さまざまな言語とフレームワークのコーディング支援サポート。ショートカットのヒント、ライブプレビュー、ファイルウォッチャーなど。新しいプログラミング言語を学ぶのに役立つコーディング演習。プラグイン設定を開くを押して設定を開き、を選択します。マーケットプレースタブを使用して、JetBrains マーケッ...

インスペクションを実行する

PhpStorm は、エディターで開かれたファイル内のコードを分析し、入力時に問題のあるコードをハイライトします。さらに、選択したファイル範囲に対して必要なインスペクションまたは一連のインスペクションを手動で実行できます。この場合、ファイル内で検出されたすべての問題に関する包括的なレポートが得られます。現在のファイルの即時分析:IDE は継続的にコードをチェックし、問題を検索します。エディターの右上隅にあるウィジェットには、現在のファイルで検出された各重大度の問題の数が表示されます。ウィジェッ...

インスペクションの重大度を変更する

インスペクション重大度レベルは、検出されたコードの問題がプロジェクトに与える影響の深刻度を示します。PhpStorm には、定義済みの一連の重大度レベルがあります。エラー構文エラー警告バグを引き起こす可能性がある、または拡張が必要なコードの断片弱い警告改善または最適化できるコードの断片 (冗長なコード、重複したコードフラグメントなど) サーバーの問題外部ビルドサーバー (TeamCity など) に起因する問題文法エラー文法の間違い。この重大度は、バンドルされている Grazie Lite プラグイン...

エディタータブ

このページを使用して、エディタータブとタブヘッダーの外観を構成し、画面上のそれらの位置を指定し、開始ポリシーと終了ポリシーを定義します。外観:タブ配置リストを使用してエディタータブの位置を設定します。なしを選択した場合、タブは表示されず、新しいファイルは現在のエディターで開きます。1 行でタブを表示するこのオプションを選択すると、タブヘッダーが 1 行に表示されます。スペースがない場合はタブを非表示にするこのチェックボックスを選択すると、PhpStorm はエディターの幅が許す限り多くのタブを...

プロジェクトツールウィンドウ

プロジェクトツールウィンドウでは、様々な視点からプロジェクトを見て、新しいアイテム(ディレクトリ、ファイル、クラスなど)の作成、エディターでのファイルのオープン、必要なコードフラグメントへの移動など、様々なタスクを実行することができます。このツールウィンドウのほとんどの機能には、コンテンツペインのコンテキストメニューコマンドとして、関連するショートカットを介してアクセスします。また、ビューには、作成されたスクラッチファイル、クエリコンソール、拡張スクリプトを管理できるスクラッチとコンソールフォル...