PhpStorm 2020.2 ヘルプ

データソースの管理

データソースは、アプリケーションのデータの場所です。PhpStorm では、以下のデータソースを定義できます。

  • データベースデータソース:データを含む運用データベース(データベース接続を参照)。

  • データ定義言語(DDL)ファイル:データ定義言語ステートメントを含む SQL ファイル。

データソースの表示オプションを構成する

データベースツールウィンドウ(表示 | ツールウィンドウ | データベース)では、オブジェクトのグループ化、色の割り当て、およびフィルターを行うことができます。

データベースツールウィンドウのオブジェクトの表示をカスタマイズする

  • データソースをグループ化、有効化、またはソートするには、データベースツールウィンドウのタイトルバーにあるオプションメニューの表示アイコンthe Show Options menu iconをクリックし、必要なオプションを選択します。

    データベースツールウィンドウ(表示 | ツールウィンドウ | データベース)では、データソースのビューが即座に変更されます。

    the Show Options menu icon

グループデータソース

多数の異なるデータベースがある場合、データベースツールウィンドウ(表示 | ツールウィンドウ | データベース)でそれらのデータソースをグループ化できます。

  1. データソースをグループ化するには、必要なデータソースを選択するか、F6 を押すか、コンテキストメニューからグループへ移動を選択します。

  2. 新しいグループを作成するには、一方のデータソースを他方にドラッグします。データソースを既存のグループに配置する場合は、既存のグループノードにドラッグします。

  3. グループからデータソースを削除するには、データソースをルートリストに移動します。

    Group data sources

データソースに色を割り当てる

本番データベースとテストデータベースを区別しやすくするために、データソースに色を割り当てることができます。

  1. データベースツールウィンドウ(表示 | ツールウィンドウ | データベース)で、データソースのプロパティアイコンThe Data Source Properties iconをクリックします。

  2. 色を割り当てるデータソースを選択します。

  3. 名前フィールドの円をクリックして、色を選択します。

    Assign a color to a data source

クエリコンソールとグリッドに色を割り当てる

  • テキストデータビューアーは、データソースの色を使用できます。色を設定するには、データソースを右クリックして色設定を選択します。データベース色設定ダイアログで、ダイアログと色付けオプションを選択します。クエリコンソールとグリッドにデータソースの色を適用するには、コンソールエディターおよびグリッドチェックボックスをオンにします。

ツールバーからオブジェクトをフィルターする

  • 必要なオブジェクトを選択するには、ツールバーthe Filter icon フィルターアイコンを使用します。

    The Filter menu

データソースを共有する

PhpStorm のデータソースは、プロジェクトとグローバルの 2 つのレベルで利用できます。プロジェクトレベルとは、このデータソースが最初に作成されたプロジェクトからのみデータソースにアクセスできることを意味します。グローバルレベルでは、他のプロジェクトでもデータソースを利用できます。デフォルトでは、プロジェクトレベルでデータソースを利用できます。

IDE 内の異なるプロジェクト間でデータソースを共有するには、データソースをグローバルレベルに移動する必要があります。

別のプロジェクトで同じデータソースを使用する必要があるが、アクセシビリティレベル(プロジェクトまたはグローバル)、ユーザー、データベース接続、スキーマ設定など、要件が異なる場合は、データソースをコピーできます。

データソースのコピーを作成する

  1. データベースツールウィンドウ(表示 | ツールウィンドウ | データベース)で、データソースのプロパティボタン(the Data Source Properties button)をクリックします。

  2. データソースおよびドライバーウィンドウで、コピーするデータソースを選択します。

  3. 複製アイコン(the Duplicate icon)をクリックするか、Ctrl+D を押します。

    Copy a data source

プロジェクト間でデータソースを共有する

  1. データベースツールウィンドウ(表示 | ツールウィンドウ | データベース)で、データソースのプロパティボタン(the Data Source Properties button)をクリックします。

  2. データソースおよびドライバーウィンドウで、グローバルにするアイコン(the Make Global icon)をクリックして、データソースをグローバルレベルで使用できるようにします。

    Share data sources between projects

異なる IDE インスタンス間でデータソースを共有する

データソースに関する情報を XML 形式でクリップボードにコピーすることができます。結果の XML にはパスワード情報は含まれません。

XML スニペットを(メッセンジャーまたはメールで)別の IDE に送信してインポートすることができます。

  1. データベースツールウィンドウ(表示 | ツールウィンドウ | データベース)で、コピーしたいデータソースを選択します。

  2. 選択範囲を右クリックします。

  3. データベースツールをクリックし、データソースをクリップボードにコピーするを選択します。

  4. 別のワークステーションで、表示 | ツールウィンドウ | データベースをクリックします。

  5. データベースツールウィンドウで、新規アイコンthe New iconをクリックし、クリップボードからインポートを選択します。

    Share data sources between different IDE instances

データソース設定の共有

settings.zip ファイルを使用して、データソース設定をエクスポートおよびインポートできます。settings.zip ファイルには、グローバルレベルで使用可能なデータソースのみが含まれます。レベルを変更する方法の詳細については、プロジェクトレベルをグローバルに変更するを参照してください。

データソース設定のエクスポート

  1. ファイル | IDE 設定の管理 | 設定のエクスポートをクリックします。

  2. 設定のエクスポートウィンドウで、選択なしをクリックします。

  3. 設定のエクスポートウィンドウで、データベース : ドライバーデータベース : 設定、およびデータベース : グローバルソースを選択します。エクスポートリストにデータベース : グローバルソースを含めるには、少なくとも 1 つのグローバルデータソースが必要です。

  4. 設定のエクスポートフィールドに、settings.zip ファイルを保存するフォルダーへのパスを入力します。

データソース設定のインポート

  1. ファイル | IDE 設定の管理 | 設定のインポートをクリックします。

  2. インポートするファイルの場所ウィンドウで、エクスポートした settings.zip ファイルを見つけてダブルクリックします。

  3. インポートするコンポーネントの選択ウィンドウで、データベース : ドライバーデータベース : 設定、およびデータベース : グローバルソースを選択します。

  4. OK をクリックします。

  5. 再開が必要ウィンドウで、OK をクリックして IDE を再起動します。

  6. データソースおよびドライバーウィンドウを開き、データソースプロパティに必要な接続資格情報を入力します。データソースがローカルまたはネットワークドライブ上にある場合は、このデータソースへのパスが正しいことを確認してください。

  7. データソースへの接続が正常に行われるようにするには、接続のテストをクリックします。

最終更新日 : 2020 年 9 月 23 日