IntelliJ IDEA 2020.2ヘルプ

マクロ

マクロは、コードの作成中に頻繁に繰り返す手順を自動化する便利な方法を提供します。マクロの記録、編集、再生、ショートカットの割り当て、共有ができます。

  • マクロを使用して、エディター関連の一連のアクションをファイル内で組み合わせることができます。

  • ボタンのクリック、ポップアップへの移動、ツールウィンドウ、メニュー、ダイアログへのアクセスを記録することはできません。

一時マクロは名前なしで使用できます。常時マクロの場合は、一意の名前を割り当てます。

マクロを記録する

  1. 編集メニューを開き、マクロをポイントし、マクロの記録を開始をクリックします。

  2. 必要なアクションを実行して記録します。

  3. the Stop button を押すか、編集 | マクロ | マクロの記録を停止を選択します。

  4. マクロ名の入力ダイアログで、新しいマクロの名前を指定し、OKをクリックします。

    マクロが一時的な使用のみを目的としている場合は、名前を空白のままにすることができます。

マクロを再生する

  • 一時マクロを再生するには、編集メニューを開き、 マクロをポイントし、最後のマクロの再生をクリックします。

  • 名前付きマクロを再生するには、編集メニューを開き、マクロをポイントして、必要なマクロ名をクリックします。

マクロの編集...

  • 編集メニューを開き、マクロをポイントし、マクロの編集...をクリックします。

キーボードショートカットをマクロにバインドする

  1. 設定/環境設定ダイアログ Ctrl+Alt+Sで、キーマップを選択します。

  2. 新しいキーマップを作成する、またはキーマップのリストから既存のキーマップを選択します。

  3. マクロノードを展開し、キーボードショートカットを作成するマクロを選択します。

  4. マクロを右クリックし、コンテキストメニューでキーボード・ショートカットの追加を選択します。

  5. キーボードショートカットを入力ダイアログで、ショートカットとして使用するキーの組み合わせを押します。

    キーストロークはすぐに最初のストロークフィールドに反映されます。必要に応じて、2 番目のストロークチェックボックスを選択し、2番目のストロークを指定します。キーを押すと、プレビューフィールドには押したキーストロークが表示され、キーストロークがすでに使用されている場合は競合フィールドに警告が表示されます。

  6. マウスポインターを使用してOKをクリックし、マクロにショートカットを割り当てます。

  7. 変更を適用します。

サンプル: 再フォーマットと保存を1つのアクションに組み合わせる

この例は、現在のファイル Ctrl+Alt+L再フォーマットし、 Ctrl+Sを押したときにプロジェクトを保存するマクロを作成する方法を示しています。

マクロを記録する

  1. エディターで任意のファイルを開きます。

  2. メインメニューから編集 | マクロ | マクロの記録を開始を選択します。

  3. Ctrl+Alt+L を押して、コード(コード | コードの再フォーマット)を再フォーマットします。次に、Ctrl+S を押してすべての変更を保存します(ファイル | すべて保存)。IntelliJ IDEAは、実行されたアクションをステータスバーに表示します。

    Macro recording
  4. the Stop button をクリックするか編集 | マクロ | マクロの記録を停止を選択して、記録を停止します。

  5. マクロ名の入力ダイアログで、新しいマクロの名前を指定し、OKをクリックします。

    Enter Macro Name dialog

新しいマクロのショートカットを割り当てる

  1. 設定/環境設定ダイアログ Ctrl+Alt+Sで、キーマップを選択します。

  2. マクロノードを展開し、作成された再フォーマットして保存マクロを選択します。

  3. マクロを右クリックし、コンテキストメニューでキーボード・ショートカットの追加を選択します。

    Add Keyboard Shortcut
  4. キーボードショートカットを入力ダイアログで、ショートカットとして使用する Ctrl+S を押し、OKをクリックします。

  5. IntelliJ IDEAは、ショートカットが別のアクションに割り当てられていることを警告します。除去をクリックして、ファイル | すべて保存アクションの Ctrl+S ショートカットを削除します。必要に応じて、後でいつでも再割り当てできます。

  6. 変更を適用するには、OKをクリックします。

ここで、Ctrl+Sを押すと、IntelliJ IDEAは新しいマクロを呼び出します。現在のファイルを再フォーマットしてプロジェクトを保存します。

最終更新日: 2020年8月19日

関連ページ:

キーボードショートカットの構成

IntelliJ IDEAには定義済みのキーマップがいくつか含まれており、頻繁に使用するショートカットをカスタマイズできます。キーマップ構成を表示するには、設定/環境設定ダイアログ を開き、キーマップを選択します。IntelliJ IDEAは、環境に基づいて事前定義されたキーマップを自動的に提案し...

コードの再フォーマットと再配置

IntelliJ IDEAでは、コード・スタイル設定で指定した要件に従ってコードを再フォーマットできます。ただし、プロジェクトでEditorConfigを使用する場合、ファイルで指定されたオプションは、コードを再フォーマットするときにコードスタイル設定で指定されたオプションをオーバーライドします。設...

著作権

プロジェクトは著作権で保護したいファイルを含んでいるかもしれません。各ファイルに別々に著作権表示を挿入する代わりに、著作権プロファイルを使用できます。プロファイルは、著作権通知テキストと、このテキストが組み込まれる一連のファイル(スコープ)を定義します。同じプロジェクト内のファイルには、いくつかの異...

国際化とローカライゼーション

国際化対応(i18n)は、ソースコードから文字列を抽出し、一連の値でプロパティとして提示するプロセスを指します。ローカライゼーション(l10n)は、これらのプロパティの値をターゲット言語に変換するプロセスを指します。ターゲット言語のキーと値は、専用のプロパティファイルに保存されます。これらのファイル...