IntelliJ IDEA 2021.1 ヘルプ

エディターの基本

IntelliJ IDEA エディターは、コードの作成、読み取り、変更に使用する IDE の主要部分です。

エディターは次の領域で構成されています。

Editor details
  1. スクロールバーには、現在のファイルのエラーと警告が表示されます。

  2. パンくずリストは、現在のファイルのコード内を移動できます。

  3. ガターには、行番号とアノテーションが表示されます。

  4. タブには、現在開いているファイルの名前が表示されます。

ナビゲーション

さまざまなショートカットを使用して、エディターウィンドウとさまざまなツールウィンドウを切り替えたり、エディターサイズを変更したり、フォーカスを切り替えたり、元のレイアウトに戻ることができます。

エディターペインを最大化する

  • エディターで、Ctrl+Shift+F12 を押します。IntelliJ IDEA はアクティブなエディターを除くすべてのウィンドウを隠します。

    分割画面を最大化することもできます。この場合、アクティブな画面が最大化され、他の画面は脇に移動します。

ウィンドウからエディターにフォーカスを切り替える

  • Escape を押す。IntelliJ IDEA はフォーカスを任意のウィンドウからアクティブなエディターに移動します。

コマンドラインターミナルからエディターに戻る

  • Alt+F12 を押す。IntelliJ IDEA はターミナルウィンドウを閉じます。

  • アクティブなエディターに戻ったときにターミナルウィンドウを開いたままにしておく必要がある場合は、Ctrl+Tab を押します。

デフォルトのレイアウトに戻る

  • Shift+F12 を押します。

  • 現在のレイアウトをデフォルトとして保存するには、メインメニューからウィンドウ | 現在のレイアウトをデフォルトに設定を選択します。同じショートカット Shift+F12 を使用して、保存されたレイアウトを復元できます。

最後のアクティブウィンドウにジャンプする

  • F12 を押します。

ナビゲーションにスイッチャーを使う

  1. 開いているファイルとツールウィンドウをスイッチャーで切り替えるには、Ctrl+Tab を押します。

  2. スイッチャーポップアップを開いたままにするには、Ctrl を押し続けます。

  3. 要素間を移動するには Tab を押します。選択したファイルをリストから削除してエディターで閉じるには、Backspace を押します。

IDE の外観を変更する

スキーム、キーマップ、または表示モードを切り替えることができます。

  1. Ctrl+` を押します。

  2. 切り替えメニューで、必要なオプションを選択し、Enter を押します。同じショートカット Ctrl+` を使用して、変更を元に戻します。

また、エディター | カラースキームページの視力多様性者向けのハイコントラストカラースキームや、設定 / 環境設定ダイアログ Ctrl+Alt+Sキーマップページのキーマップ設定など、カラースキーム設定を見つけて調整することもできます。

  • Alt + Home を押します。

スクロールバー

エディターでコードを操作すると、IntelliJ IDEA は、エラーと警告を含むコード分析結果をスクロールバーに表示します。コードに問題があるかどうかを確認し、すばやくそれらに移動できます。

スクロールバーの上部には、インスペクションウィジェットがあり、コードの問題の簡単な要約が表示されます。ウィジェットをクリックして、問題ツールウィンドウで検出された各問題の詳細情報を取得します。

Code analysis summary

詳細は、現在のファイルを参照してください。

スクロールバーのストライプは、IntelliJ IDEA が問題を見つけた場所を示しています。ストライプにカーソルを合わせると、問題を説明するツールチップが表示されます。または、ストライプをクリックすると、すばやく移動できます。

ファイルで作業している間、多くのストライプが表示されるのは正常です。コードを完了すると、これらのエラー、警告、提案の多くは最終的に解決されます。コードが完成したと感じてもエラーが残る場合は、プロジェクトをコンパイルする前に、エラーを調査して解決することをお勧めします。

ストライプの異なる色は、赤でマークされたエラーから青でマークされた TODO コメントまで、問題の重大度を示しますが、必要に応じて表示される色を変更できます。詳細については、インスペクションの重大度を変更するを参照してください。

エディタータブ

エディタータブを閉じたり、隠したり、切り離したりできます。ファイルを編集用に開くたびに、その名前のタブがアクティブなエディタータブの横に追加されます。

エディタータブの設定を構成するには、設定 / 環境設定ダイアログ Ctrl+Alt+Sエディター | 一般 | エディタータブページを使用します。または、タブを右クリックして、オプションのリストからエディタータブの構成を選択します。

タブを開くまたは閉じる

  • 開いているタブをすべて閉じるには、メインメニューからウィンドウ | エディタータブ | すべてのタブを閉じるを選択します。

  • 非アクティブなタブをすべて閉じるには、Alt を押してアクティブなタブの the Close button をクリックします。この場合、アクティブなタブだけが開いたままになります。

  • アクティブなタブと固定されたタブを除くすべての非アクティブなタブを閉じるには、任意のタブを右クリックして他のタブを閉じるを選択します。

  • アクティブなタブだけを閉じるには、Ctrl+F4 を押します。タブ上の任意の場所でマウスのホイールボタンをクリックして閉じることもできます。

  • 閉じたタブを再度開くには、任意のタブを右クリックして、コンテキストメニューから閉じたタブを再度開くを選択します。

  • すでに開いているタブの最後に新しいタブを開くには、タブ設定新しいタブを最後に追加するを選択します。

パスまたはファイル名をコピー

  1. タブを右クリックします。

  2. 表示されたリストからパスをコピーを選択します。

  3. 表示されるリストから、コピーオプションを選択します。
    Copy path

    IntelliJ IDEA はアイテムをクリップボードにコピーし、必要な場所に貼り付けることができます(Ctrl+V)。

タブを移動、削除、または並べ替える

  • タブ上の the Close button アイコンを移動または削除するには、設定 / 環境設定ダイアログ Ctrl+Alt+Sエディター | 一般 | エディタータブに移動し、閉じるボタンの位置フィールドで適切なオプションを選択します。

  • エディタータブをエディターフレームの別の部分に配置したり、タブを非表示にしたりするには、タブを右クリックしてエディタータブの構成を選択し、エディタータブ設定を開きます。外観セクションのタブ配置リストで、適切なオプションを選択します。

  • エディタータブをアルファベット順にソートするには、タブを右クリックしてエディタータブの構成を選択してエディタータブ設定を開きます。タブ順セクションで、タブをアルファベット順でソートするを選択します。

タブの固定または固定解除

エディターでアクティブなタブを固定して、タブの制限に達したとき、または他のタブを閉じるコマンドを使用したときに開いたままになるようにすることができます。

  • アクティブなタブを固定または固定解除するには、タブを右クリックして、コンテキストメニューからタブをピン留めまたはタブのピン留め解除を選択します。

  • 固定されているタブ以外のすべてのタブを閉じるには、任意のタブを右クリックしてピン留め以外をすべて閉じるを選択します。

  • タブをピン留めアクションにキーボードショートカットを割り当てるには、設定 / 環境設定ダイアログ Ctrl+Alt+Sキーマップに移動し、アクティブなタブを固定アクションを見つけて右クリックし、キーボードショートカットの追加を選択して、使用するキーの組み合わせを押します。

タブを切り離す

  • アクティブなタブを切り離すには、Shift+F4 を押します。

  • 必要なタブをメインウィンドウの外側にドラッグし、タブを後ろにドラッグして取り付けます。

  • 同じアクションに Alt+mouse を使用することもできます。

  • プロジェクトツールウィンドウで、デタッチしたいファイルを選択して Shift+Enter を押します。

タブを切り替える

  • タブ間を移動するには、Alt+Right または Alt+Left を押します。

  • 最近表示したタブやファイルを切り替えることもできます。

    エディターで、Ctrl+Tab を押します。スイッチャーウィンドウが開いたままになるように Ctrl を押し続けます。タブと他のファイルを切り替えるには Tab を使います。

開いたタブにショートカットを割り当てる

  1. 設定 / 環境設定ダイアログ Ctrl+Alt+S で、キーマップに移動します。

  2. ディレクトリのリストで、その他ディレクトリをクリックし、タブのリストからショートカットを追加する必要があるものを選択します。ショートカットを割り当てることができるタブの制限は 9 です。

    Add shortcuts for tabs

デフォルトのタブ制限を変更する

IntelliJ IDEA は、エディターで同時に開くことができるタブの数を制限します(デフォルトのタブ制限は 10 です)。

  1. 設定 / 環境設定ダイアログ Ctrl+Alt+S で、エディター | 一般 | エディタータブに移動します。

  2. タブの終了ルールセクションで、好みに合わせて設定を調整し、OK をクリックします。

プレビュータブでファイルを開く

プレビュータブでは、新しいタブで各ファイルを開かなくても、1 つのタブでファイルを 1 つずつ表示できます。これは、タブの制限を超えずに複数のファイルを調べる必要がある場合に役立ちます。

  1. プロジェクトツールウィンドウ Alt+1 で、the Show Options Menu button をクリックし、プレビュータブの有効化オプションを選択します。

    設定 / 環境設定 | 一般 | エディタータブ | 開くポリシーでプレビュータブを有効にすることもできます。

  2. プロジェクトツールウィンドウで、他のタブでまだ開いていないファイルを選択します。

    ファイルの名前は、プレビューモードを示すために斜体で表記されています。選択した他のファイルは、プレビュータブの前のファイルを置き換えます。

    ファイルの編集を開始してプレビューモードを終了し、通常のタブに変更します。

    The preview tab

    プレビュータブが有効になっている場合、シングルクリックでファイルを開くオプションは無視されることに注意してください。ファイルをダブルクリックして、通常のタブで開きます。

スペースがなくなったらエディタータブを隠す

  1. 設定 / 環境設定ダイアログ Ctrl+Alt+S で、エディター | 一般 | エディタータブに移動します。

  2. スペースがない場合はタブを非表示にするオプションを選択してください。追加のタブは、エディターの右上部分にあるリストに配置されます。

タブのフォントサイズを変更する

  1. 設定 / 環境設定ダイアログ Ctrl+Alt+S で、外観 & 振る舞い | 外観に移動します。

  2. サイズフィールドでフォントサイズを指定し、OK をクリックして変更を保存します。

    フォントサイズはタブだけでなく、ツールウィンドウでも変わることに注意してください。

画面を分割

IntelliJ IDEA は、メインメニューまたはコンテキストメニュー、エディター、またはプロジェクトツールウィンドウから呼び出してエディター画面を分割できるさまざまなアクションを提供します。

  • エディターで、目的のエディタータブを右クリックし、エディターウィンドウを分割する方法(右に分割または下に分割)を選択します。IntelliJ IDEA はエディターの分割ビューを作成し、選択に従って配置します。

  • 別の方法として、メインメニューからウィンドウ | エディタータブ分割して右に移動または分割して下に移動オプションを選択します。

    必要に応じて、これらのアクションにキーボードショートカットを割り当てることができます。これを行うには、設定 / 環境設定ダイアログ Ctrl+Alt+S で、キーマップに移動し、右に分割または下に分割アクションを見つけて右クリックし、キーボードショートカットの追加を選択して、使用するキーの組み合わせを押します。分割して右に移動または分割して下に移動アクションについても同じことができます。

  • エディターを分割するためにタブを垂直または水平にドラッグし、画面を分割解除するためにタブをドラッグして戻すことができます。

    Drag-and-drop tab
  • 右の分割でエディターでファイルを開くことができます。

    プロジェクトツールウィンドウで、ファイルを右クリックし、コンテキストメニューから右に分割して開くを選択します(または Shift+Enter を押します)。IntelliJ IDEA は、エディターの右側の分割でファイルを開きます。

    Right split

    2 つの分割があり、フォーカスが左側の分割にある場合、ファイルは既存の右側の分割で開かれます。フォーカスが右分割にある場合、ファイルは次の右分割で開かれます。

  • 分割画面間でファイルを移動できます。エディターで必要なファイルタブを右クリックし、コンテキストメニューからエディターを反対のタブグループに移動または反対側で開くを選択します。

  • アクティブな分割画面を最大化できます。最大化する画面にカーソルを置き、Ctrl+Shift+F12 を押します。

    この場合、IntelliJ IDEA はすべてのツールウィンドウを非表示にし、他の分割画面を脇に移動します。

    別の方法として、アクティブな分割画面をダブルクリックして最大化することもできます。

  • 画面の分割を解除するには、コンテキストメニューから分割しないまたは分割をすべて解除を選択して、分割されたすべてのフレームの分割を解除します。

分割画面を移動する

  1. キャレットを目的の分割フレーム内に配置します。

  2. メインメニューからウィンドウ | エディタータブを選択します。

  3. オプションのリストから、次のオプションのいずれかを選択します。

    • エディターを上に伸縮

    • エディターを左に伸縮

    • エディターを下に伸縮

    • エディターを右に伸縮

    各オプションにショートカットを割り当て、キーボードを使用して分割フレームを引き伸ばすことができます。

    作成した分割フレーム間を移動するには、メインメニューからウィンドウ | エディタータブを選択します。オプションのリストから、それぞれ次の分割へ移動 Alt+Tab または前の分割に移動 Alt+Shift+Tab を選択します。

便利なエディター構成

設定 / 環境設定ダイアログ Ctrl+Alt+S を使用して、エディターの動作をカスタマイズできます。

editor settings

次の一般的な設定を確認してください。

コードフォーマットを設定する

  1. 設定 / 環境設定ダイアログ Ctrl+Alt+S で、エディター | コードスタイルに移動します。

  2. 言語のリストから適切な言語を選択し、言語ページで、タブとインデント、スペース、折り返しと中括弧、ハードマージンとソフトマージンなどの設定を構成します。

フォント、サイズ、フォント合字を設定する

  • 設定 / 環境設定ダイアログ Ctrl+Alt+S で、エディター | フォントに移動します。

エディターでフォントサイズを変更する

  1. 設定 / 環境設定ダイアログ Ctrl+Alt+S で、エディター | 一般マウスコントロールセクション)に進みます。

  2. Ctrl+ マウスホイールでフォントをサイズ変更するオプションを選択してください。

  3. エディターに戻って Ctrl を押したままマウスホイールを使ってフォントサイズを調整します。

さまざまな言語およびフレームワーク用に配色設定を構成する

  1. 設定 / 環境設定ダイアログ Ctrl+Alt+S で、エディター | カラースキームに移動します。

  2. カラースキームノードを開き、必要な言語またはフレームワークを選択してください。ノードのリストから一般オプションを選択して、コード、エディター、エラーと警告、ポップアップとヒント、検索結果などの一般的な項目の配色設定を構成することもできます。

コード補完オプションを設定する

  • 設定 / 環境設定ダイアログ Ctrl+Alt+S で、エディター | 一般 | コード補完に移動します。ここでは、大文字と小文字を区別する補完、自動表示オプション、コードの並べ替えなどを構成できます。

キャレット配置を設定する

  • 設定 / 環境設定ダイアログ Ctrl+Alt+S で、エディター | 一般に移動します。仮想スペースセクションでは、キャレット配置オプションを構成できます。

    前の行の終わりと同じ位置にある次の行にキャレットを配置するには、行末以降へのキャレット移動を許可するオプションを選択します。このオプションをオフにすると、次の行のキャレットは実際の行の末尾に配置されます。

    タブ文字内へのキャレット移動を許可するオプションを選択すると、ファイルを同じ位置に保ちながらキャレットをファイル内で上下に移動できます。

保存時の末尾スペースの動作を設定する

  • 設定 / 環境設定ダイアログ Ctrl+Alt+S で、エディター | 一般に移動します。その他セクションでは、後続スペースのオプションを構成できます。

    例: コードを手動または自動で保存し、保存時に行末のスペースを除去するリストで選択されているオプションに関係なくキャレット行の末尾のスペースを保持したい場合は、キャレット行末尾の空白を保持するオプションを選択します。

エディターの外観オプションを設定する

  • 設定 / 環境設定ダイアログ Ctrl+Alt+S で、エディター | 一般 | 外観に移動します。

    例: ハードラップガイドの表示やパラメーターヒントの表示を設定できます。

長い行の外観を管理する

  1. 設定 / 環境設定ダイアログ Ctrl+Alt+S で、エディター | 一般に移動します。

  2. 行の折り返しセクションで、適切なオプションを指定します。

    例: ソフトラップを適用するファイルタイプを指定できます。マークダウンファイルでドキュメントを作成するときに役立ちます。

スマートキーを設定する

使用する言語に応じて、さまざまな基本的なエディターアクションの特定の動作を構成できます。

  • 設定 / 環境設定ダイアログ Ctrl+Alt+S で、エディター | 一般 | スマートキーに移動します。

    例: Java、SQL、Python の場合は、タブで閉じ括弧 / 引用符の外に移動するオプションを選択してクローズ角括弧の外でのナビゲーションを有効にするか、コードを入力するときに Tab でクォートします。

関連ページ:

ソースコードの作成と編集 | IntelliJ IDEA

コードを使用する場合、IntelliJ IDEA は作業にストレスがないことを保証します。追加、選択、コピー、移動、編集、折りたたみ、出現箇所の検索、コードの保存に役立つさまざまなショートカットと機能を提供します。エディター内のナビゲーションについては、エディターの基本を参照してください。アクションの検索使用したいアクションのショートカットを覚えていない場合は、を押して名前でアクションを見つけてください。同じダイアログを使用してクラス、ファイル、またはシンボルを見つけることができます。詳しくは...

ソースコードナビゲーション | IntelliJ IDEA

さまざまなアクションやポップアップを使用して、エディター内のコードを素早くナビゲートすることができます。エディターウィンドウとツールウィンドウ間の移動に関する詳細情報については、エディターの基本を確認してください。IntelliJ IDEA で利用可能なナビゲーションオプションをチェックするためにビデオチュートリアルを見ることから始めることができます。キャレットでナビゲートする後方に移動するには、を押します。前方に移動するには、を押します。最後に編集した場所に移動するには、を押します。エデ

インスペクションの重大度を変更する | IntelliJ IDEA

インスペクションの重大度は、検出されたコードの問題がプロジェクトにどれほど深刻な影響を及ぼすかを示します。すべての重要度レベルには、独自のハイライトスタイルがあります。IntelliJ IDEA には、事前定義された重大度レベルのセットがあります。エラー: 構文エラーをマークします。警告: バグを生成したり、機能拡張を必要とする可能性のあるコードフラグメントをマークします。弱い警告: 改善または最適化できるコードフラグメントをマークします(冗長コード、重複したコードフラグメントなど)。サーバーの...

エディタータブ | IntelliJ IDEA

このページを使用して、エディタータブとタブヘッダーの外観を構成し、画面上のそれらの位置を指定し、開始ポリシーと終了ポリシーを定義します。外観:タブ配置リストを使用してエディタータブの位置を設定します。なしを選択した場合、タブは表示されず、新しいファイルは現在のエディターで開きます。タブを 1 行で表示するこのオプションを選択すると、タブヘッダーが 1 行に表示されます。スペースがない場合はタブを非表示にするこのチェックボックスを選択すると、IntelliJ IDEA はエディターの幅が許す限り...

プロジェクトツールウィンドウ | IntelliJ IDEA

プロジェクトツールウィンドウでは、様々な視点からプロジェクトを見て、新しいアイテム(ディレクトリ、ファイル、クラスなど)の作成、エディターでのファイルのオープン、必要なコードフラグメントへのナビゲートなど、様々なタスクを実行することができます。ビュー:ツールウィンドウにはいくつかのビューがあります。プロジェクトビュー。このビューには、すべてのプロジェクトアイテムとその依存関係(SDK およびライブラリ)が表示されます。パッケージも示されていますが、ディレクトリ構造に重点が置かれています。パッケ...

キーボードショートカットを設定する | IntelliJ IDEA

IntelliJ IDEA には定義済みのキーマップがいくつか含まれており、頻繁に使用するショートカットをカスタマイズできます。キーマップ構成を表示するには、設定 / 環境設定ダイアログを開き、キーマップを選択します。IntelliJ IDEA は、環境に基づいて事前定義されたキーマップを自動的に提案します。使用している OS と一致することを確認するか、使用している別の IDE またはエディターからのショートカットと一致するものを選択してください(たとえば、Eclipse または NetBe...