IntelliJ IDEA 2020.3 ヘルプ

JavaScript リンター

IntelliJ IDEA は、ESLint(英語) およびその他の最も一般的な JavaScript コードリンターと統合され、コードを実行せずにコードの問題を検出します。

インストールして有効にすると、JavaScript ファイルを開くたびにリンターが自動的にアクティブになり、検出されたエラーと警告が報告され、可能な場合はクイックフィックスが提案されます。

現在のファイルで検出されたエラーの説明とそれらのクイックフィックスは、エディターおよび問題ツールウィンドウの現在のファイルタブから入手できます。

以前に開いたすべてのファイルのエラーとそれらのクイックフィックスは、問題ツールウィンドウのプロジェクトエラータブに表示されます。ツールウィンドウを開くには、エディターの右上隅にあるインスペクションウィジェットをクリックします。

Inspection widget

詳細は、エディターで問題を表示してクイックフィックスを適用するおよび問題ツールウィンドウを参照してください。

エディターで問題を表示してクイックフィックスを適用する

  1. エディターで、ハイライトされた問題の上にマウスポインターを置きます。IntelliJ IDEA は、問題の説明を含むツールチップを表示します。

    JavaScript linters: errors and warnings are highlighted, the description of a problem is shown in a tooltip.

    この問題を解決するには、<リンター名>: 「<ルール名>」を修正をクリックするか、Alt+Shift+Enter を押します。

  2. 現在のファイルで検出されたすべての問題を解決するには、その他のアクションAlt+Enter)をクリックして、リストから <リンター名>: 現在のファイルを修正を選択します。

    JavaScript linters: resolving problems

    または、Alt+Enter を押して、リストから関連する提案を選択します。

問題ツールウィンドウ

問題ツールウィンドウを開くには、エディターの右上隅にあるインスペクションウィジェットをクリックします。

Inspection widget

または、メインメニューから表示 | ツールウィンドウ | 問題を選択するか、Alt+6 を押します。

問題ツールウィンドウは、次の 2 つのタブで構成されています。

  • 現在のファイルタブには、アクティブなエディタータブからファイルで検出されたエラーが表示されます。

    Problems tool window, TypeScript. Current File tab shows syntax errors from the file in the active editor tab
  • プロジェクトエラータブには、以前に開いたすべてのファイルのエラーが、検出されたファイルごとにグループ化されたエラーメッセージとともに表示されます。

    Problems tool window, TypeScript. Project Errors tab shows syntax errors across the project

エラーごとに、IntelliJ IDEA は簡単な説明とエラーが発生した行の番号を示します。エラーメッセージから、問題が発生したコードに移動するか、クイックフィックスを適用するか、エディタープレビューペイン( the Open Preview button )で問題を手動で修正できます。

  • 問題ツールウィンドウを開くには、エディターの右上隅にあるインスペクションウィジェットをクリックします。

    Inspection widget

    または、メインメニューから表示 | ツールウィンドウ | 問題を選択するか、Alt+6 を押します。

  • 問題の推奨クイックフィックスを表示するには、対応するエラーメッセージを選択し、コンテキストメニューからクイックフィックスの表示を選択するか、ツールバーの the Show Quick Fixes button をクリックするか、Alt+Enter を押します。

    問題を修正するには、リストから適切なクイックフィックスを選択します。

    Problems tool window: fix a problem
  • または、the Open Editor Preview button をクリックしてエディタープレビューペインを開き、ツールウィンドウを移動せずに手動で問題を修正します。

    Problems tool window: fix errors in the Editor Preview pane
  • ファイル全体で検出された問題を解決するには、コンテキストメニューから <リンター名>: 現在のファイルを修正を選択します。

  • エラーが発生した場所に移動するには、対応するエラーメッセージをダブルクリックするか、コンテキストメニューからソースに移動を選択するか、F4 を押します。

  • また、リンターの設定を編集したり、問題が発生したステートメントまたはファイル全体のルールを抑制したり、現在のファイルを分析から除外したりすることもできます。詳細については、インスペクションを無効にして抑制を参照してください。

    Problems tool window: context menu
  • エラーメッセージを重大度でフィルタリングしてソートをカスタマイズするには、the View Options button をクリックして、リスト内の関連するアイテムを選択またはクリアします。

    View Options: configuring the appearance of the Problems tool window
  • エラーメッセージをコピーするには、コンテキストメニューから問題の説明をコピーを選択するか、Ctrl+C を押します。

関連ページ:

インスペクションの無効化と有効化

いくつかのインスペクションは現在見たくない問題を報告するかもしれません。この場合、無効にしたり抑制したりできます。インスペクションを使用不可にすると、無効になります。これは、このインスペクションが検出するように設計されているという問題について、コード分析エンジンがプロジェクトファイルの検索を停止することを意味します。インスペクションを無効にすると、現在のインスペクションプロファイルで無効になります。他のプロファイルでは有効のままです。インスペクションを無効にする:設定でインスペクションを無効に

JavaScript 後置テンプレート

後置コード補完の詳細を参照してください。後置コード補完では、入力したばかりの式の周囲にテンプレートコードを追加できます。ドットの後に略語(後置)を入力して展開キー(デフォルトでは)を押すか、またはコード補完ポップアップで略語を選択すると、テンプレートが展開されます。例:式に適用された接尾辞は、それをステートメントでラップします。IntelliJ IDEA には一連の事前定義された後置テンプレートが付属しており、独自のカスタムテンプレートを定義できます。カスタム後置テンプレートを作成するを参照し...

ESLint

IntelliJ IDEA は ESLint と統合されており、プラグインでも拡張できる lint ルールの幅が広がります。IntelliJ IDEA は、ESLint によって報告された警告とエラーを入力時にエディターに表示します。ESLint では、JavaScript 標準スタイルを使用することもできます。始める前に:Node.js をダウンロードしてインストールします。ESLint をインストールする:埋め込みターミナルで、以下のいずれかのコマンドを入力します。グローバルインストール用の、...