DataGrip 2020.3 ヘルプ

テーブル

データベーステーブルは、データを行と列に編成する構造です。テーブル内のデータは、垂直列と水平行の交差部分であるセルに格納されます。テーブルには指定された数の列がありますが、任意の数の行を含めることができます。DataGrip を使用すると、テーブルを使用してデータ操作およびデータ定義操作を実行できます。

データベースツールウィンドウ(表示 | ツールウィンドウ | データベース)でテーブルをダブルクリックすると、テーブルがエディターでテーブルビューに表示されます。ビューの詳細については、データを表示するを参照してください。

DataGrip では、各テーブルが個別のタブで開きます。長いタブタイトルには、次のルールが適用されます。

  • データベースオブジェクトの修飾名を常に表示するオプションはデフォルトでオフになりました。同じ名前のオブジェクトの 2 つのタブを開くと、オブジェクトのタブ名が修飾されます。例: 異なるスキーマから 2 つの actor テーブルを開くと、スキーマ名がタブ名に追加されます。

  • データソースの名前が 20 シンボルより長い場合、名前は切り捨てられます。

  • データソースが 1 つしかない場合、DataGrip はデータソース名をタブ名に表示しません。

  • 修飾オブジェクト名に 36 を超える記号がある場合、切り捨てられます。

Working with tables
トピック テーブルタスク
作成および削除 テーブルを作成および削除する方法について説明します。
変更 テーブル構造の変更方法、データベースとテーブルの説明の追加方法、テーブルの読み取り専用モードの有効化方法について説明します。
フィルター データを表示するさまざまなモード、テーブルを転置する方法、エディターに表示されるデータをデータベースのコンテンツと同期する方法について説明します。
データを表示する データを表示するさまざまなモード、テーブルを転置する方法、エディターに表示されるデータをデータベースのコンテンツと同期する方法について説明します。
比較 2 つのテーブル構造、または 2 つのテーブルの内容を比較する方法について説明します。

PostgreSQL の地理データに Geo ビューアーを使用する

Geo ビューアーは、データベース内の空間データを探索するために使用できるグラフィックビューアーです。サービスツールウィンドウで Geo ビューアーが開きます。行をクリックしてマップ上の対応する領域に移動するか、マップ上のピンをクリックして対応する行に移動できます。

ジオビューアータブをサービスツールウィンドウから切り離すには、サービスツールウィンドウからドラッグします。

現在、DataGrip は次の形式の座標をサポートしています: WKT、WKB、PostGIS ジオメトリ 4326。

The Geo Viewer

Geo ビューアーで地理データを表示する

  1. データベースツールウィンドウ(表示 | ツールウィンドウ | データベース)で、地理データを含むテーブルをダブルクリックします。

  2. オプションメニューを表示アイコン( Show Options Menu icon )をクリックし、地域ビューアーを表示を選択します。

  3. JCEF を有効にすることの潜在的なリスクに関する通知を参照してください。リスクを受け入れる場合は、JCEF を有効にするをクリックします。

  4. 再起動が必要ですウィンドウで、今すぐ再起動をクリックします。

  5. 再起動後、Ctrl+F5 を押すか、地理的データを含むテーブルを再度開きます。

  6. オプションメニューを表示アイコン( Show Options Menu icon )をクリックし、地域ビューアーを表示を選択します。

  7. View geographical data with the Geo viewer

JCEF を有効にした後に DataGrip を回復する

  1. config ディレクトリに移動します。

    構文
    %HOMEPATH%\.<product><version>\config\projects
    サンプル
    C:\Users\JohnS\.DataGrip2020.3\config\projects
    構文
    ~/Library/Application Support/<product><version>
    サンプル
    ~/Library/Application Support/DataGrip2020.3
    構文
    ~/.<product><version>/config/plugins
    サンプル
    ~/.DataGrip2020.3/config/plugins
  2. options ディレクトリで、ide.general.xml をテキストエディターで開きます。

  3. 次の行を削除します: <entry key="ide.browser.jcef.enabled" value="true" />

関連ページ:

データを表示する

データベースツールウィンドウでテーブルをダブルクリックすると、データエディターでテーブルが開きます。テーブルデータは、Table、ツリー、テキスト、文字の入れ替えの 3 つのモードで参照および編集できます。これらのモードを切り替えるには、次として表示ボタンをクリックして、必要なモードを選択します。テーブル: テーブルデータのデフォルトの表示モード。テーブル内のデータは、垂直列と水平行の交点であるセルに格納されます。ツリー: データが Key-Value テーブルに表示される表示モードで、子ノード...

作成および削除

テーブルの作成データベースツールウィンドウで、データソースを選択してに移動します。新しいテーブルを作成するダイアログで、テーブル設定(列、キー、インデックス、外部キー)を指定します。OK をクリックします。テーブルを削除するテーブルを削除するには、テーブルを右クリックして DROP()を選択します。SQL プレビューフィールドで生成されるコードに追加のオプションを設定できます。スキーマ名でオブジェクトを修飾する: スキーマ名をテーブル名に追加します。異なるスキームに同じ名前のテーブルが 2 つ以上...

変更

テーブルを修正するデータベースツールウィンドウで、テーブルを右クリックしてテーブルの変更を選択します。テーブルの変更ダイアログで、必要なテーブル設定を指定します。データエディターからテーブルを変更するテーブルデータの編集中にテーブルを変更できます。テーブルをダブルクリックして、データエディターで開きます。を押します。テーブルデータを変更します。実行をクリックします。を押してページを再ロードします。テーブルの読み取り専用モードを有効にするデータエディターでの偶発的な変更からテーブルを保護するために...

フィルター

次の方法を使用して、テーブルのデータをフィルタリングできます。フィルタリング条件を手動で指定するか、クイックフィルタリングオプションを使用できます。クイックオプションは、現在の列名のフィルタリング条件です。条件は、現在のセルの値によって異なります。を押してテーブルで検索を実行することにより、行をフィルタリングできます。行フィルターを使用して、フィルター基準フィールドにクエリを書き込むことにより、テーブルのデータをフィルター処理できます。クイックフィルタリングオプションを使用するクイックフィルタリ...

比較

2 つのテーブル構造を比較して、列、キー、インデックス、その他の構造テーブル要素の違いを確認できます。また、選択したテーブルのデータを比較して、値の違いを確認することもできます。ダイアログコントロールの詳細については、「データベースオブジェクトの差分ビューアー」を参照してください。2 つの表を比較データベースツールウィンドウで、2 つのテーブルを選択します。選択範囲を右クリックして、比較に移動します。データベースツールウィンドウから 2 つのテーブルの内容を比較するデフォルトでは、クエリを発行す...

データ抽出

データエクストラクターは、エディターで(テキストビューモードで)データをコピーまたは表示する方法のルールを設定します。データのエクスポートアイコンの近くのリストからデフォルトの抽出プログラムを選択するか、既存の抽出プログラムを構成するか、Groovy または JavaScript を使用してカスタム抽出プログラムを作成できます。いくつかの組み込みフォーマットがあります。データを INSERT または UPDATE ステートメントのセットとしてエクスポートできます。また、CSV、JSON、HTML...