DataGrip 2019.3ヘルプ

ツールウィンドウの操作

ツールウィンドウを表示する

以下のいずれか 1 つを実行します:

  • ワークスペースの左下隅にある Icon for quick access to tool windows をポイントし、表示されるメニューでツールウィンドウを選択します。

  • ツールウィンドウバーの対応するツールウィンドウボタンをクリックします。

  • メインメニューの表示 | ツール・ウィンドウ | <ツールウィンドウ>を選択します。

  • ツールウィンドウにクイックアクセス番号が関連付けられている場合は、Alt を押します(たとえば、プロジェクトツールウィンドウの場合は、Alt + 1を押します。

個々のツールウィンドウを非表示にする

以下のいずれか 1 つを実行します:

  • ツールウィンドウバーの対応するツールウィンドウボタンをクリックします。

  • ツールウィンドウのタイトルバーで hide をクリックします。

  • 対応するツールウィンドウボタンを右クリックし、コンテキストメニューから非表示を選択します。

  • ツールウィンドウのタイトルバーを右クリックし、コンテキストメニューから非表示を選択します。

  • メインメニューの表示 | ツール・ウィンドウ | <ツールウィンドウ>を選択します。

  • ツールウィンドウにクイックアクセス番号が関連付けられている場合は、Alt を押します(たとえば、プロジェクトツールウィンドウの場合は、Alt + 1を押します。

  • 非表示にするツールウィンドウが現在アクティブな場合は、Shift+Escapeを押します。

同じツールウィンドウバーに接続されているすべてのツールウィンドウを非表示にする

以下のいずれか 1 つを実行します:

  • Altを押したまま、対応するツールウィンドウバーに接続されたツールウィンドウのタイトルバーで hide をクリックします。

  • メインメニューのウィンドウ | アクティブ・ツール・ウィンドウ | サイドのツール・ウィンドウを非表示を選択します。このコマンドは、同じツールウィンドウバーにアタッチされているすべてのツールウィンドウを、アクティブなツールウィンドウまたはアクティブなツールウィンドウの最後に隠します。

すべてのツール・ウィンドウを閉じる

以下のいずれか 1 つを実行します:

  • メインメニューのウィンドウ | アクティブ・ツール・ウィンドウ | すべてのウィンドウを閉じるを選択します。

  • Ctrl+Shift+F12を押します。

最後のアクティブなツールウィンドウに切り替える

以下のいずれか 1 つを実行します:

  • メインメニューのウィンドウ | アクティブ・ツール・ウィンドウ | 最後のウィンドウに移動を選択します。

  • F12を押します。

すべてのツールウィンドウが現在非表示になっている場合は、最後にアクティブなツールウィンドウが表示され、アクティブになります。

ツールウィンドウバーの非表示または表示

DataGripウィンドウ内にさらにスペースが必要な場合は、すべてのツールウィンドウバーを非表示にすることができます。

  • ワークスペースの左下隅にある Hide tool window barをクリックします。

ツールウィンドウバーが隠れている場合は、永続的にまたは短時間の間画面に戻すことができます:

  • ツールウィンドウバーを復元するには、ワークスペースの左下隅にある Show tool window bar をクリックします。

  • ツールバーのウィンドウバーを短時間表示するには、Altを2回押し続けます。ツールウィンドウバーが画面に表示され、ツールウィンドウボタンにアクセスできるようになります。キーを放すと、ツールウィンドウバーが再び非表示になります。

ツールウィンドウボタンを非表示

DataGripは、対応するプラグインを実際にアンインストールすることなく、個々のツールウィンドウボタンを隠すことを可能にします。

隠しツールウィンドウボタンを元に戻すには、メインメニューから表示 | ツール・ウィンドウを選択し、隠しツールバーボタンがあるウィンドウをクリックします。

  1. ツールウィンドウのバーが表示されていることを確認します。

  2. 非表示にするツールウィンドウのボタンを右クリックします。

  3. サイドバーから除去を選択します。

ツールウィンドウを別のツールウィンドウバーに接続する

次のいずれかのアクションを実行して、ツールウィンドウを別のツールウィンドウバーにアタッチできます。

  • 対応するツールウィンドウボタンを目的のツールウィンドウバー(上、左、下または右)にドラッグします。

  • 対応するツールウィンドウのボタンまたはツールウィンドウのタイトルバーを右クリックしてコンテキストメニューを開きます。移動を選択し、目的のツールウィンドウバー(または)を選択します。

ツールウィンドウのサイズを変更する

次のいずれかのアクションを実行して、ツールウィンドウのサイズを変更できます。

  • マウスポインタをツールウィンドウ枠の上に移動します。ポインタが双方向の矢印になったら、境界線を必要な方向にドラッグします。

  • また、境界線を左または右に、または上または下にステップ移動してツールウィンドウのサイズを変更することもできます。それには次のような選択肢があります。

    • 対応するツールウィンドウのボタンまたはタイトルバーを右クリックし、サイズ変更を選択します。次に、使用可能な伸縮オプションの1つを選択します。

    • 関心のあるツールウィンドウをアクティブにして、次のいずれかの操作を行います。

      • ウィンドウ | アクティブ・ツール・ウィンドウ | サイズ変更を選択し、必要な伸縮オプションを選択します。

      • 対応する矢印キーと組み合わせて Ctrl+Shift を押します。

一度に表示されるツールウィンドウの数を増やす

一度に表示されるツールウィンドウの数を増やすには、さまざまなツールウィンドウの表示モードを適切に設定する必要があります。次の点を考慮してください。

  • 一般に、ツールウィンドウが常に表示されるようにする(つまり、非アクティブの場合でも)には、ツールウィンドウを固定する必要があります。

  • 表示可能なフローティングウィンドウの数とウィンドウモードのフローティングウィンドウの数に制限はありません。

  • 最初は、3つ(4つのうち3つ)のツールウィンドウバーが使用されています。特定のツールウィンドウを移動することで、4つ目のツールウィンドウバー(上の1つ)を「アクティブ化」することができます。

ツールウィンドウの配置を保存および復元する

メインメニューのウィンドウ | 現在のレイアウトをデフォルトとして保管を選択すると、ツールウィンドウの配置方法を保存できます。

後で、ウィンドウ | デフォルト・レイアウトの復元 Shift+F12を選択して、保存されたワークスペースレイアウトに戻ることができます。

最終更新日: 2020年2月20日