CLion 2018.3ヘルプ

ツール・ウィンドウの操作

ツールウィンドウを表示する

以下のいずれか 1 つを実行します:

  • ワークスペースの左下隅にある show tool window bars をポイントし、表示されるメニューでツールウィンドウを選択します。

  • ツールウィンドウバーの対応するツールウィンドウボタンをクリックします 。

  • メインメニューの表示 | ツール・ウィンドウ | <ツールウィンドウ>を選択します。

  • ツールウィンドウに関連するクイックアクセス番号がある場合は、 Alt (WindowsおよびLinuxユーザの場合)または (macOSユーザの場合)キーを押します(たとえば、プロジェクトツールウィンドウの場合は Alt+1 (WindowsまたはLinuxユーザの場合)または ⌘+1 (macOSユーザーの場合)。

個々のツールウィンドウを非表示にする

以下のいずれか 1 つを実行します:

  • ツールウィンドウバーの対応するツールウィンドウボタンをクリックします 。

  • ツールウィンドウのタイトルバーで hide をクリックします。

  • 対応するツールウィンドウボタンを右クリックし、コンテキストメニューから非表示を選択します。

  • ツールウィンドウのタイトルバーを右クリックし、コンテキストメニューから非表示を選択します。

  • メインメニューの表示 | ツール・ウィンドウ | <ツールウィンドウ>を選択します。

  • ツールウィンドウに関連するクイックアクセス番号がある場合は、 Alt (WindowsおよびLinuxユーザの場合)または (macOSユーザの場合)キーを押します(たとえば、プロジェクトツールウィンドウの場合は Alt+1 (WindowsまたはLinuxユーザの場合)または ⌘+1 (macOSユーザーの場合)。

  • 非表示にするツールウィンドウが現在アクティブな場合は、 Shift+Escapeを押します。

同じツールウィンドウバーに接続されているすべてのツールウィンドウを非表示にする

以下のいずれか 1 つを実行します:

  • Alt (WindowsおよびLinuxユーザの場合)または (macOSユーザの場合)キーを押したまま、対応するツールウィンドウバーに接続されているツールウィンドウのタイトルバーで hide をクリックします。

  • メインメニューのウィンドウ | アクティブ・ツール・ウィンドウ | サイドのツール・ウィンドウを非表示を選択します。このコマンドは、同じツールウィンドウバーにアタッチされているすべてのツールウィンドウを、アクティブなツールウィンドウまたはアクティブなツールウィンドウの最後に隠します。

すべてのツールウィンドウを隠す

以下のいずれか 1 つを実行します:

  • メインメニューのウィンドウ | アクティブ・ツール・ウィンドウ | すべてのウィンドウを閉じるを選択します。

  • Ctrl+Shift+F12を押します。

最後にアクティブなツールウィンドウに切り替える

以下のいずれか 1 つを実行します:

  • メインメニューのウィンドウ | アクティブ・ツール・ウィンドウ | 最後のウィンドウに移動を選択します。

  • F12を押します。

すべてのツールウィンドウが現在非表示になっている場合は、最後にアクティブなツールウィンドウが表示され、アクティブになります。

ツールのウィンドウバーを非表示または表示する

CLionウィンドウにさらにスペースが必要な場合は、すべてのツールウィンドウバーを非表示にすることができます。

  • ワークスペースの左下隅にある show hide tool window barsをクリックします。

ツールウィンドウバーが隠れている場合は、それらを永続的にまたは短時間の間画面に戻すことができます:

  • ツールウィンドウバーを復元するには、ワークスペースの左下隅にある show tool window bars をクリックします。

  • ツールバーのウィンドウを短時間表示するには、 Alt (WindowsおよびLinuxユーザーの場合)または (macOSユーザーの場合)キーを2回押して保持します。ツールウィンドウのバーが画面に表示され、ツールウィンドウのボタンにアクセスできます。ツールバーのウィンドウバーは、キーを離すと再び非表示になります。

ツールウィンドウのボタンを隠す

CLionは、実際に対応するプラグインをアンインストールせずに、個々のツールウィンドウボタンを隠すことができます。

ビューからツールウィンドウボタンを削除するには:

  1. ツールウィンドウのバーが表示されていることを確認します 。

  2. 非表示にするツールウィンドウのボタンを右クリックします。

  3. サイドバーから除去を選択

cl tool window button hide

隠しツールウィンドウボタンを復元するには、メインメニューで表示 | ツール・ウィンドウを選択し、非表示のツールバーボタンでウィンドウをクリックします。

別のツールウィンドウバーにツールウィンドウをアタッチする

以下のいずれか 1 つを実行します:

  • 対応するツールウィンドウボタンを目的のツールウィンドウバー(上、左、下または右)にドラッグします。

    cl tool window buttons drag

  • 対応するツールウィンドウのボタンまたはツールウィンドウのタイトルバーを右クリックしてコンテキストメニューを開きます。移動を選択し、目的のツールウィンドウバー(または)を選択します。

ツールウィンドウのサイズ変更

  • マウスポインタをツールウィンドウ枠の上に移動します。ポインタが双方向の矢印になったら、境界線を必要な方向にドラッグします。

  • また、境界線を左または右に、または上または下にステップ移動してツールウィンドウのサイズを変更することもできます。それには次のような選択肢があります。

    • 対応するツールウィンドウのボタンまたはタイトルバーを右クリックし、サイズ変更を選択します。次に、使用可能な伸びるオプションの1つを選択します。

    • 関心のあるツールウィンドウをアクティブにして、次のいずれかの操作を行います。

      • ウィンドウ | アクティブ・ツール・ウィンドウ | サイズ変更を選択し、必要な伸びるオプションを選択します。

      • 対応する矢印キーと組み合わせて Ctrl+Shift を押します。

一度に表示されるツールウィンドウの数を増やす

一度に表示されるツールウィンドウの数を増やすには、さまざまなツールウィンドウの表示モードを適切に設定する必要があります。次の点を考慮してください。

  • 一般に、ツールウィンドウが常に表示されるようにするには(つまり、非アクティブになっている場合でも)、ツールウィンドウを固定する必要があります。

  • 表示可能なフローティングウィンドウの数とウィンドウモードのフローティングウィンドウの数に制限はありません。

    Note that the windowed mode is not available if you are using macOS.
  • 一度に同じツールウィンドウバーにドッキングされた2つのウィンドウを表示できるようにするには、ウィンドウの1つに分割モードをオフにし、もう1つをオンにする必要があります 。

  • 最初は、3つ(4つのうち3つ)のツールウィンドウバーが使用されています。特定のツールウィンドウを移動することで、4つ目のツールウィンドウバー(上の1つ)を「アクティブ化」することができます。

ツールウィンドウの配置の保存と復元

メインメニューのウィンドウ | 現在のレイアウトをデフォルトとして保管を選択すると、ツールウィンドウの配置方法を保存できます。

後でウィンドウ | デフォルト・レイアウトの復元Shift+F12)を選択すると、保存したワークスペースレイアウトに戻ることができます。

最終更新日: 2018年12月7日

関連事項